[Wine] New Winecfg crash

Robert Reif reif at earthlink.net
Fri Dec 9 16:46:39 CST 2005

Evil wrote:

>I updated my copy of WINE CVS today, and now if I click the audio tab in
>Winecfg, I'm getting this on my Mandrake 2006 machine.
>*** glibc detected *** free(): invalid pointer: 0x7c0a6cd0 ***
>wine: Assertion failed at address 0xffffe410 (thread 0009), starting
>This happens everytime I run winecfg and click the audio tab.  Clicking
>the other tabs works fine.
>I've updated to the latest KDE 3.5 CVS and made many other changes since
>I last modified my WINE audio settings, so I'm not entirely sure WINE is
>at fault yet.
>Has anyone else seen this problem too - before I waste much time on it?
>WINE (even sound output) seems to work fine other than this one bug.
>wine-users mailing list
>wine-users at winehq.org
I'm not real surprised.  The latest winecfg now loads all sound drivers
it finds.  Some of the drivers have had little widespread testing on
different software and hardware configurations so small problems
are bound to show up.

What you need to do is determine which driver is causing the problem.
I would start with the least used ones like nas, esd, and jack.  You
can go to /usr/local/lib/wine and rename wine?.drv.so where ? is nas,
esd, arts, jack, oss and alsa to something else until winecfg runs
without problems. You could also comment out each driver in
wine/programs/winecfg/properties.c and recompile winecfg
until you find it.

Once the driver is identified, we can figure out where the problem is
and fix it.

Sorry for the short term incontinences but the bugs should be
worked out quickly once they are identified.

More information about the wine-users mailing list