[Wine]Newbie: Running an application within wine (installed fine)

Holly Bostick motub at planet.nl
Thu Feb 3 16:12:42 CST 2005


Please remember to use "Reply to all" when responding to this list; 
otherwise your message will only go to the original sender and not the list.

Therefore this message is fully quoted, so that your previous reply will 
also go to the list.

Bottom-posting (posting your reply below the quoted text) is also 
preferred (otherwise it gets confusing following the thread of problem 
and suggested solution).

דותן כהן wrote:
> I just tried- nothing. I just sit and wait. No output, nothing.
> Where is this menu link that you mention? I see none in the KDE menu,
> is this the menu that you mean?

I'm using wine 20050111 with SuSE 9.2, and I was surprised as well when 
I installed Planescape: Torment and suddenly I had a Wine folder in the 
KDE menu, with a link to the program, with an icon, even (!!!).

I have to assume this is a new functionality of Wine, or possibly a 
"special" quality related to SuSE (which loves KDE a great deal, and 
integrates a lot of 'internal functions' with it). If a new function of 
Wine, then perhaps an upgrade will enable it; if specific to the SuSE 
package, then I'm just lucky :-) .

In any case, the fact that this lovely link exists yet does not work for 
me (I had to write a little shell script that cds to the program 
directory, then runs the main executable with wine, otherwise the 
program gives an error and will not start) is of no use to you if your 
program will not start nor give output even when started directly from 
within the program's install folder.

However, the fact that it isn't working could be due to a couple of factors:

1) How are you stopping the process when the program fails to start? Is 
there possibly a wineserver still running from a previous failed 
attempt? Please check a process monitor such as KDE System Guard and 
kill any wineservers or leftover running Wine processes before trying 
again to run the program from its install directory.

2) The fact that no output whatsoever is being produced is suspicious, 
insofar as it suggests that the program is not crashing (in which case 
there would be output of some sort), but stuck somewhere along the way 
to running.

Does this program need to contact some external device such as a scanner 
or camera before starting?

You are running these commands from a terminal, correct?


> Dotan
> On Thu, 03 Feb 2005 22:23:36 +0100, Holly Bostick <motub at planet.nl> wrote:
>>��ת� ��� wrote:
>>>I had successfully installed BrilliantPhoto with wine, so that I have
>>>the directory:
>>>file:/home/dotancohen/.wine/c/Program Files/Brilliant Labs/BrilliantPhoto
>>>but when I run the command
>>>wine /home/dotancohen/.wine/c/Program\ Files/Brilliant\
>>>it justs sits there with no output until I ctrl-Z it. Silly me, I even
>>>tried to click the icon in Konqueror to start the program (I can start
>>>IE6 this way).
>>>I just installed wine (with apt, version 20041201) and winetools
>>>within the last few hours, and between what I've see on this list the
>>>past few weeks (I subscribed in December) and google, well, I know
>>>nothing! I'm on Fedora Core 3 in KDE on a AMD Duron 1 ghz machine with
>>>512mb ram and a noisy fan.
>>>Thank you in advance!
>>>Dotan Cohen
>>Some programs don't like to run via a full path; what happens if you cd
>>to the Brilliant Photo directory first, then run
>>wine BrilliantPhoto.exe
>>I have a couple of apps that run fine when the app is run from within
>>the program directory, but fail to run otherwise (even from the program
>>menu link created by Wine during the program's install).

More information about the wine-users mailing list