[Wine]wine, wineserver, and x.org using 100% of CPU

Michael W. Lucas mwlucas at blackhelicopters.org
Thu Jan 20 07:18:34 CST 2005


I installed Wine 20050111 on my FreeBSD 6-current (freshly updated
yesterday afternoon) to play SimCity 2000.

Whenever I start the program with "wine SIMCITY.EXE", the various
start-up pop-ups appear, as well as the dialog asking if you want to
start a new city, open an old city, etc.  I get the side toolbar.  The
main window where you play the game is never drawn, however; it starts
off as a very small window, and when I expand it it remains blank.

Additionally, the wine, wineserver, and Xorg processes start competing
amongst themselves for CPU.  CPU idle time immediately goes to 0.

The output from running wine:

# wine /home/mwlucas/.wine/drive_c/Program\ Files/Maxis/SimCity\ 2000/SIMCITY.EXE 
fixme:file:get_default_drive_device auto detection of DOS devices not supported on this platform
fixme:ntdll:NtQueryVolumeInformationFile device info not properly supported on this platform
err:heap:HEAP_CreateSystemHeap system heap base address 0x80000000 not available
fixme:font:load_VDMX No suitable ratio found
fixme:mmtime:timeBeginPeriod Stub; we set our timer resolution at minimum
fixme:font:load_VDMX No suitable ratio found
fixme:font:load_VDMX No suitable ratio found
err:tooltips:TOOLTIPS_WindowProc unknown msg 0500 wp=00000000 lp=00000000
err:x11drv:X11DRV_CreateWindow invalid window width -16
err:x11drv:X11DRV_CreateWindow invalid window height -16

The first time I start Wine after boot, I get warnings on the console:

Warning: pid 650 used static ldt allocation

(with wine's pid in the place of 650, it varies with each boot of course)

To see if wine works at all, I tried notepad.exe from a w2k server.
It runs fine, without much CPU usage at all.

I had previously tried this with a FreeBSD-current from 12/20/04 and
Wine 20041201.  That version had the same CPU usage problem, but the
main screen was actually drawn and the game could be played.  The
CPU-usage-caused lag was monstrous, and aiming the mouse was a
nightmare, but it could be done.

I'm at a loss to even figure out how to debug this.  Any suggestions?



("Play a fun old game to blow off steam, man.  How hard could it be?"
Sheesh.  :-)

Michael W. Lucas	mwlucas at FreeBSD.org, mwlucas at BlackHelicopters.org
	       Latest book: Cisco Routers for the Desperate

More information about the wine-users mailing list