[Wine]no sound

Baurzhan Ismagulov ibr at radix50.net
Sat Jul 2 14:12:13 CDT 2005


I was playing the German version of StarCraft under Debian sid with wine
20050524 without Windows. I had "HardwareAcceleration" = "Emulation" in
[dsound] section of ~/.wine/config. I had the following problem: after
playing for a while without problems (sound was ok), wine said
"fixme:wave:OSS_AddRingMessage two fast messages in the queue!!!! toget
= 29(WINE_WM_RESTARTING), tosave=30(UNKNOWN(0x00000000))", and the
program started to emit loud unpleasant sound (no music or character
sounds at all, just a chaotic sound, like that of an AM radio not tuned
on a specific station).

So I decided to try today's cvs. I built it with sid's gcc 3.3.5 and run
"LD_LIBRARY_PATH=/opt/w/lib /opt/w/bin/wine
~/.wine/c/Programme/Starcraft/StarCraft.exe". It said:

err:wave:DSDB_MapBuffer Could not map sound device for direct access (Input/output error)
err:wave:DSDB_MapBuffer Use: "HardwareAcceleration" = "Emulation" in the [dsound] section of your config file.

and there was no sound at all.

I checked strace output to make sure that wine didn't read
~/.wine/config. In cvs log server/registry.c I found an entry dated
2005-07-01 saying that we don't read config any more. So I tried to put
the entry in [dsound] and [Software\\Wine\\dsound] sections of
~/.wine/user.reg, but wine didn't seem to notice it. I also tried
winecfg -> Audio with OSS and ALSA, but neither worked (autodetect found

How can I get the sound with this game? I would appreciate any advice.

I have VIA 823x sound chip and use the following modules under sid's
2.6.10-1-k7: snd_seq_oss snd_seq_midi_event snd_seq snd_pcm_oss
snd_mixer_oss snd_via82xx snd_ac97_codec snd_pcm snd_timer
snd_page_alloc gameport snd_mpu401_uart snd_rawmidi snd_seq_device snd

Thanks in advance,

More information about the wine-users mailing list