[Wine]Printing Problem

Markus Kobel mkobel at biko.ch
Sun Jun 19 17:53:35 CDT 2005


I attached the log file that I got with the following command:
WINEDEBUG=warn+all wine BUSPRO.EXE &> wine.log

There are a lot of lines like the following:

warn:psdrv:PSDRV_WriteNewPage WriteSpool error

And they end with a:

fixme:psdrv:PSDRV_EndPage Already ended a page?
warn:psdrv:PSDRV_WriteFooter WriteSpool error
warn:psdrv:PSDRV_EndDoc CloseJob error
warn:gdi:GDI_GetObjPtr Invalid handle (nil)

As written in the log, the application wants to read a file / create a file:

warn:file:wine_nt_to_unix_file_name L"-PRINT.INI" not found in
warn:ntdll:NtCreateFile L"\\??\\C:\\BUSPRO\\BIKO\\-PRINT.INI" not found

But I still get no output on any printer. In the cups log, I see, that
wine loads the ppd files - but that is all. There is no file in the CUPS
queue ever.
Any help would be appreciated!

Kind regards

Markus Kobel wrote:
> Thank you for the quick answer and sorry for my late reply.
> I just tried to get the printing work. Unfortunately, it did not work
> with the ppd-entry. :(   I still have the same problem (print -> no
> error message -> printer does nothing).
> I also tried with wine version 20050524 and also with a version built
> from CVS.
> I also generated some stack-traces (printing from the BusPro-Application
> and printing from Notepad - WINEDEBUG=+relay). As said before, printing
> from Notepad is working. One difference I have seen is the following
> error when I try to print from BusPro:
> 0009:Call kernel32.WideCharToMultiByte(00000000,00000000,7fddc5e0
> L"Range check error",00000011,7fc5fac0,000003ff,00000000,00000000)
> ret=7fac9d69
> Is this 'Range check error' a problem?
> And other hints?
> Kind regards
> Markus Kobel
> Frank Spaan wrote:
>>I had the same problem.
>>Get the ppd file for your printer (just google around) or download from 
>>http://www.adobe.com/support/downloads/main.html and save it for example
>>in /usr/local/share/wine.
>>Make this entry in your wine config file :
>>"generic" = "/usr/local/share/wine/generic.ppd"
>>Markus Kobel wrote:
>>>I have a problem with an accounting software called BusPro. I can run
>>>the program without any error. But when I want to print (over cups),
>>>nothing happens. I do not even get an error message or something like
>>>that. I tried to print out of Notepad - this is working.
>>>I get the following output on the command line:
>>>fixme:richedit:RichEditANSIWndProc EM_EXLIMITTEXT: stub
>>>fixme:richedit:ME_ReleaseStyle all style references freed (good!)
>>>fixme:richedit:RichEditANSIWndProc EM_EXLIMITTEXT: stub
>>>fixme:psdrv:PSDRV_EndPage Already ended a page?
>>>fixme:richedit:ME_ReleaseStyle all style references freed (good!)
>>>I tried with wine versions 20050310 and 20050419.
>>>Is there a trick to make it work? Tell me if you need a full stack trace
>>>or some other information.
>>>Kind regards
>>>Markus Kobel
>>>wine-users mailing list
>>>wine-users at winehq.org
>>wine-users mailing list
>>wine-users at winehq.org
> _______________________________________________
> wine-users mailing list
> wine-users at winehq.org
> http://www.winehq.org/mailman/listinfo/wine-users
-------------- next part --------------
A non-text attachment was scrubbed...
Name: wine.log.tgz
Type: application/x-gtar
Size: 9918 bytes
Desc: not available
Url : http://www.winehq.org/pipermail/wine-users/attachments/20050620/e1ac9296/wine.log.tgz

More information about the wine-users mailing list