[Wine]Running DOS program in a cron job

Patrick Naef Patrick.Naef at schiller.ch
Tue Jun 28 08:39:23 CDT 2005


I'm trying to run a DOS program within a cron job. After much trial-and-error I settled on the following approach:

- rm -r ~/.wine

- call wine without any arguments, this lets wine generate a default configuration in ~/.wine

- change ~/.wine/config: set GraphicsDriver to ttydrv instead of x11drv

- the cron job consists of a shell script that runs the DOS program with "wcmd /c"

The whole thing works when I run the shell script interactively, over a non-X11 ssh connection. However, when I run the shell script via cron, wcmd prints the following on stderr:

Error opening terminal: unknown.

I have tried setting (and exporting) TERM to a number of devices, among them /dev/null or /dev/tty1, but this didn't help. I have tried chown'ing the device to the user that runs the cron job, again with no success.

Has someone got an idea what I'm doing wrong? Should I use a different approach? Should I use wineconsole instead of wcmd (how?)?

Thanks for any help

Btw: I'm running wine-20050419 on SuSE 9.1. I already tried upgrading to wine-20050524, but this release seems to ignore ttydrv completely...

Patrick Näf / Software Engineer
SCHILLER AG, Altgasse 68, CH-6341 Baar, Switzerland
Phone +41 (0)41 766 42 42 / Fax +41 (0)41 761 08 80
Direct Phone / Voice Box +41 (0)41 766 43 52
patrick.naef at schiller.ch / www.schiller.ch 

More information about the wine-users mailing list