[Wine]ZBrush 2 - Unhandled exception (thread 0009), starting debugger -

Luca Bonatti luka_26 at tin.it
Wed May 4 07:22:01 CDT 2005

I'm having big troubles in installing and running Zbrush 2 with WineHQ.
I've compiled different versions of wine (included the last one) and 
each one gives me the same messages and errors.
I've tried to install ZBrush with the installer, but it hangs in the 
middle of the process.
So I've installed it on Windows to get the files extracted. When I run 
ZBrush.exe on wine I experience these problems:

- If wine is set to "winxp" a pop up tells me that I've got to unload 
the debugger.
- If wine is set to "win2k" I get this message:

         > wine ZBrush2.exe
        wine: Unhandled exception (thread 0009), starting debugger...
        Usage: winedbg [--auto] [--gdb] cmdline

And then if I write:

                   > winedbg --auto ZBrush.exe
i get:

        WineDbg starting on pid 0xa
        In 32 bit mode.
        0x432ce6e6 start_process+0xca
        in kernel32: jmp       0x432ce6dc start_process+0xc0
        in kernel32
        Unable to open file
        Module  Address                 Debug info      Name (67 modules)
        PE      0x00400000-0145e000     Deferred        zbrush2
        ELF     0x429bd000-429e2000     Deferred        winspool.drv<elf>
          \-PE  0x429d0000-429e2000     \               winspool.drv
        ELF     0x429e2000-42a84000     Deferred        comctl32<elf>
          \-PE  0x429f0000-42a84000     \               comctl32
        ELF     0x42a84000-42aa2000     Deferred        iphlpapi<elf>
          \-PE  0x42a90000-42aa2000     \               iphlpapi
        ELF     0x42aa2000-42ae7000     Deferred        rpcrt4<elf>
          \-PE  0x42ac0000-42ae7000     \               rpcrt4
        ELF     0x42ae7000-42b62000     Deferred        ole32<elf>
          \-PE  0x42b00000-42b62000     \               ole32
        ELF     0x42b62000-42bb7000     Deferred        shlwapi<elf>
          \-PE  0x42b80000-42bb7000     \               shlwapi
        ELF     0x42bb7000-42c6b000     Deferred        shell32<elf>
          \-PE  0x42bd0000-42c6b000     \               shell32
        ELF     0x42c6b000-42cf3000     Deferred        comdlg32<elf>
          \-PE  0x42c80000-42cf3000     \               comdlg32
        ELF     0x42cf3000-42d6b000     Deferred        winmm<elf>
          \-PE  0x42d00000-42d6b000     \               winmm
        ELF     0x42d6b000-42da5000     Deferred        advapi32<elf>
          \-PE  0x42d80000-42da5000     \               advapi32
        ELF     0x42da5000-42e23000     Deferred        gdi32<elf>
          \-PE  0x42dc0000-42e23000     \               gdi32
        ELF     0x42e23000-42f30000     Deferred        user32<elf>
          \-PE  0x42e40000-42f30000     \               user32
        ELF     0x4325f000-43360000     Stabs           kernel32<elf>
          \-PE  0x43290000-43360000     \               kernel32
        ELF     0x4347d000-43488000     Deferred        libnss_files.so.2
        ELF     0x43488000-4357c000     Deferred        libwine_unicode.so.1
        ELF     0x43594000-43602000     Deferred        ntdll<elf>
          \-PE  0x435b0000-43602000     \               ntdll
        ELF     0x43602000-4361a000     Deferred        ld-linux.so.2
        ELF     0x4361c000-43746000     Deferred        libc.so.6
        ELF     0x43748000-4376b000     Deferred        libm.so.6
        ELF     0x4376d000-43771000     Deferred        libdl.so.2
        ELF     0x43773000-4383a000     Deferred        libx11.so.6
        ELF     0x4383c000-4384a000     Deferred        libxext.so.6
        ELF     0x4384c000-4385c000     Deferred        libz.so.1
        ELF     0x43872000-4387a000     Deferred        libsm.so.6
        ELF     0x4387c000-43894000     Deferred        libice.so.6
        ELF     0x43896000-438fd000     Deferred        libfreetype.so.6
        ELF     0x438ff000-43925000     Deferred        libfontconfig.so.1
        ELF     0x43927000-43946000     Deferred        libexpat.so.0
        ELF     0x43961000-43969000     Deferred        libxrender.so.1
        ELF     0x4396b000-4396e000     Deferred        libxrandr.so.2
        ELF     0x43970000-43979000     Deferred        libxcursor.so.1
        ELF     0x43a02000-43a07000     Deferred        libxxf86dga.so.1
        ELF     0x449de000-449e3000     Deferred        libxxf86vm.so.1
        ELF     0x774db000-774f0000     Deferred        midimap.drv<elf>
          \-PE  0x774e0000-774f0000     \               midimap.drv
        ELF     0x7760b000-7762d000     Deferred        msacm32<elf>
          \-PE  0x77610000-7762d000     \               msacm32
        ELF     0x7762d000-77645000     Deferred        msacm.drv<elf>
          \-PE  0x77630000-77645000     \               msacm.drv
        ELF     0x77645000-77684000     Deferred        wineoss.drv<elf>
          \-PE  0x77660000-77684000     \               wineoss.drv
        ELF     0x776d1000-776ef000     Deferred        imm32<elf>
          \-PE  0x776e0000-776ef000     \               imm32
        ELF     0x776ef000-7770b000     Deferred        ximcp.so.2
        ELF     0x7770b000-7770d000     Deferred        xlcutf8load.so.2
        ELF     0x777ad000-777af000     Deferred        libnvidia-tls.so.1
        ELF     0x777af000-77f00000     Deferred        libglcore.so.1
        ELF     0x77f00000-77f03000     Deferred        <wine-loader>
        ELF     0x77f11000-77f89000     Deferred        libgl.so.1
        ELF     0x77f89000-78000000     Deferred        x11drv<elf>
          \-PE  0x77fa0000-78000000     \               x11drv
        ELF     0xb7fd0000-b7fe8000     Deferred        libwine.so.1
        process  tid      prio (all id:s are in hex)
        0000000a (D) C:\Program Files\Pixologic\ZBrush2\ZBrush2.exe
                0000000b    0 <==
        WineDbg terminated on pid 0xa

Someone can help me? What can I do to solve the problem?
The previous versione of Zbrush runs without big problems.             

More information about the wine-users mailing list