[Wine]Re: Access 97 on Wine 20041019

jurgen thinger at gmail.com
Thu May 5 20:51:27 CDT 2005


Thanks everyone for your help so far, but it's still not going anywhere.

I found the Workgroup editor thing: c:\windows\system\wrkgadm.exe and ran 
it, set up a workgroup. However, when it went to save the file, I got a 
useful Microsoft error: "An error has occurred at changing workgroup 
database". The file was not created. It's not a permissions error, because I 
can create all kinds of files in that directory. I even tried saving the 
file someplace else, even in the H: (~jurgen) directory, but I always get 
the same error. Wine doesn't report anything at all on the command line.

Taking a different angle, using a system.mda from another computer, 
wrkgadm.exe seems to accept it, but running Access gives me an out of memory 

What else can I try? I have a legal copy of Win98SE here, and I'm not averse 
to running "real" Microsoft DLLs if it will get Access working.



On 05/05/05, Jörg Schaible <joerg.schaible at gmx.de> wrote:
> jurgen wrote:
> > Hi all,
> >
> > I'm having trouble getting Access 97 working with Wine 20041019. Word 
> and
> > Excel work just fine, as far as I've used them, but Access simply 
> refuses
> > to start. I've installed off an original installer CD through the
> > WineTools ( 2.11jo) utility. I customised the install, removing 
> everything
> > except for the basic application files for Word, Excel and Access. I've
> > also installed all of the Base Setup and all of the Windows System
> > Software from WineTools.
> >
> > During install, it complains about not being able to update the 
> workgroup
> > database, but the install completes fine anyway. When I navigate to
> > Access's folder and type "wine MSACCESS.EXE", the splash screen comes up
> > just fine, then a second later, I get an error dialogue box:
> >
> > Microsoft Access couldn't find the file "C:\windows\system\system.mdw".
> > This file is required for startup.
> >
> > Doing a bit of reasearch, I learnt that this file has something to do 
> with
> > Access's workgroup (tee hee) functions. I tried touching the file and
> > setting it to 777, also tried copying system.mdw from a "real" Windows
> > machine, but both of these solutions ends up with an out of memory
> > dialogue on launch. It's progress though, I got a *different* error. :-)
> IIRC there is a utility installed in the access directory to switch and
> create new workgroups. Other system.mda's won't work, since they are
> created individually for your system at installation time. Try to run this
> tool and create a new one and switch the access system to it.
> - Jörg
> _______________________________________________
> wine-users mailing list
> wine-users at winehq.org
> http://www.winehq.org/mailman/listinfo/wine-users

thinger at gmail.com is jurgen's gmail address.
Visit http://jurgen.ca/ for more yummy goodness.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.winehq.org/pipermail/wine-users/attachments/20050506/164ae90a/attachment.html

More information about the wine-users mailing list