[Wine] Re: MS Visual FoxPro DECLARE command doesnt work

Markus Winhard mw at bingo-ev.de
Fri Nov 4 09:38:58 CST 2005

<< I've not had much luck getting Visual FoxPro running under wine >>

    No real problem with Wine 0.9. Vfp 9.0 runs out of the box. 
Unfortunately the WAIT WINDOW bug and the ToolTipText bug are not solved 
since 2003. I didn't try to install Vfp9 as I can access the installed 
copy on my windows fat32 partition.

<< DECLARE INTEGER ShellExecute IN shell32.dll ;
ShellExecute( 0, "open", "notepad.exe", "", "", 1 )

With no paths to shell32.dll. This is what works with Windows, and 
should also work with wine. >>

    This was my first try with wine20041019, too. The DECLARE statement 
raised an error (shell32.dll not found). So I tried referencing 
shell32.dll.so directly. Then the DECLARE statement succeeded but the 
actual call to ShellExecute() failed.
    Unfortunately I cannot check if it works in 0.9 because VMWare 
killed my X-Server when I tried to run my Knoppix installation within 
VMWare. Have to solve that first. :-(((

Markus Winhard

More information about the wine-users mailing list