[Wine] Re: MS Visual FoxPro DECLARE command doesnt work

Duane Clark dclark at akamail.com
Fri Nov 4 12:47:16 CST 2005

Markus Winhard wrote:
> << I've not had much luck getting Visual FoxPro running under wine >>
>     No real problem with Wine 0.9. Vfp 9.0 runs out of the box. 
> Unfortunately the WAIT WINDOW bug and the ToolTipText bug are not solved 
> since 2003. I didn't try to install Vfp9 as I can access the installed 
> copy on my windows fat32 partition.
> << DECLARE INTEGER ShellExecute IN shell32.dll ;
> ShellExecute( 0, "open", "notepad.exe", "", "", 1 )
> With no paths to shell32.dll. This is what works with Windows, and 
> should also work with wine. >>
>     This was my first try with wine20041019, too. The DECLARE statement 
> raised an error (shell32.dll not found). So I tried referencing 
> shell32.dll.so directly. Then the DECLARE statement succeeded but the 
> actual call to ShellExecute() failed.

Something to try might be to put a link to 
/usr/local/lib/wine/shell32.dll.so in your Wine C:/windows/system32 (or 
perhaps system; you could always put a link in both). VFP may be 
directly testing for the existence of the file.

More information about the wine-users mailing list