[Wine] Two issues with Diablo II

Colin Kern razael1 at gmail.com
Sat Aug 5 09:07:24 CDT 2006

The OSS drivers have their own problems.  If I try any hardware
acceleration other than "emulation", Diablo crashes with "UNHANDLED
EXCEPTION: ACCESS VIOLATION".  With emulation, the sound works in the
intro and main menu, but often when I load my game it turns into
incredibly loud static.  Occasionally it works, and the sound is fine
without the delay I get when using ALSA.


On 8/5/06, Patrick May <dusthillresident at gmail.com> wrote:
> Hello,
> I had a similar sound problem when running Unreal in Wine. I solved the
> problem by using the OSS sound driver rather than the ALSA one whenever
> I wanted to run Unreal.
> Regards,
> - Patrick.
> Colin Kern wrote:
> > I am running Wine 0.9.18 on Ubuntu 6.06.  I was able to get Diablo II
> > running very easily, but there are two rather small problems that are
> > bugging me.
> >
> > The first is that the sound is delayed about a second from the events
> > that trigger them.  I am actually having this problem outside of
> > Diablo.  I am using the ALSA drivers.
> >
> > The other is that while the 'alt' key is held down, mouse clicks do
> > not work.  In the game, you can hold alt to see the names of items
> > that are on the floor.  Running normally on Windows, you can then
> > click on the names to pick them up, so that you don't have to hunt for
> > the pixels that make up the tiny item laying on the ground.  You could
> > also move around (by clicking) while the 'alt' key was held down.
> > Under Wine, mouse clicks have no effect while I am holding down the
> > 'alt' key.
> >
> > Has anyone seen these problems before, or know what could be causing
> > them?
> >
> > Thanks,
> > Colin
> >
> > _______________________________________________
> > wine-users mailing list
> > wine-users at winehq.org
> > http://www.winehq.org/mailman/listinfo/wine-users
> >

More information about the wine-users mailing list