[Wine] Ubuntu packages for 0.9.18 and .19 broken?

Gavin Hamill gdh at acentral.co.uk
Tue Aug 15 02:57:34 CDT 2006

On Tue, 15 Aug 2006 17:20:32 +1000
Shelton D'Cruz <sdcruz at netspace.net.au> wrote:

> try running wineprefixcreate on the console

An interesting strategy.. however I see the debugger crank up in both
cases where no ~/.wine is present, and also where a known-good one from
0.9.17 is present.

In another note, I wanted to try building my own wine debs from the
budgetdedicated repo:

deb-src http://wine.budgetdedicated.com/apt dapper main
deb http://wine.budgetdedicated.com/apt dapper main

# apt-get update
# apt-get build-dep wine

gdh at plip:~$ sudo apt-get build-dep wine
Reading package lists... Done
Building dependency tree... Done
Note, selecting libfontconfig1-dev for regex ‘libfontconfig-dev’
E: Build-dependencies for wine could not be satisfied.

Could this problem be as simple as some backported / renamed package
that Scott's packages require, but don't reference in the Dependencies:
line, something that has only slipped in since 0.9.18 ?

Out of interest I tried the Breezy Wine packages on Dapper.. and the
results were identical.. 0.9.17 is perfect, whilst .18 and .19 are a
complete flop :(

The thing that concerns me most is this in the backtrace:

=>1 0x7df5ac0e pthread_initialize+0x272 in libpthread.so.0 (0x7df5ac0e)
  2 0x7df6099f __do_global_ctors_aux+0x23 in libpthread.so.0
(0x7df6099f) 3 0x7df56a7e _init+0x12 in libpthread.so.0 (0x7df56a7e)
  4 0xb7fe12ab in ld-linux.so.2 (+0xb2ab) (0xb7fe12ab)
  5 0xb7fe13f4 in ld-linux.so.2 (+0xb3f4) (0xb7fe13f4)

Unable to start a new thread? Erk! :)

How can I get a debug build of wine (is the wine-dev package enough?)
to spew out much more information to help nail this down?


More information about the wine-users mailing list