[Wine] explorer.exe 100% kernel time?

L. Rahyen research at science.su
Mon Dec 11 08:31:34 CST 2006

On Monday December 11 2006 13:04, Flying wrote:
> i all,
> I'm new to Wine, but I did tried to search for similar problem from
> Google without success. So I think I'll just raise my question here:
> System: Ubuntu Edgy (fresh installation)
> Wine: 0.9.26~winehq0~ubuntu~6.10-1
> Hardware: P4 2.60 + 1 GB RAM
> Problem:
> 	Whenever I run an Windows application using Wine (e.g., winecfg,
> utorrent), there is an instance of explorer.exe started in the
> background. I'm fine with the additional process were it not for the
> fact that it occupies 100% CPU time (all are kernel time) on my system.
> Since my CPU has HT enabled, that basically means 50% of my CPU power is
> gone just by this explorer.exe instance.
> Question:
> 	Has anyone met similar situation before? Is there any known workaround
> to this problem?

	This isn't normal and isn't typical. There are something wrong with your Wine 
package or your system configuration. You can try to download source code 
from winehq.org: 
http://prdownloads.sourceforge.net/wine/wine-0.9.27.tar.bz2 . Then unpack, cd 
to directory with Wine source code and try to compile it by executing (if you 
have 64-bit system):

LDFLAGS="-L/lib32 -L/usr/lib32 -Wl,-rpath,/usr/lib32" \
./configure \
--x-libraries=/emul/ia32-linux/usr/X11R6/lib/ \
--x-includes=/emul/ia32-linux/usr/X11R6/include \
--with-x && \
make depend && \
make all && \
sudo make install;

	Or if you have 32-bit system:

LDFLAGS="-L/lib -L/usr/lib -Wl,-rpath,/usr/lib" \
./configure \
--x-libraries=/usr/X11R6/lib/ \
--x-includes=/usr/X11R6/include \
--with-x && \
make depend && \
make all && \
sudo make install;

	Please note that paths for your distribution may differ (if this is the case 
then change them accordingly).
	Before executing these command please uninstall your current Wine package.

More information about the wine-users mailing list