[Wine] Re: Printing - using WINE

Sven Rudolph sven at spaghetticode.de
Mon Jul 3 12:44:56 CDT 2006

Hello Klabauter,

I have exactly the same problem. Maybe you want to have a look at my
thread "REPOST: No printing possible in wine 0.9.15" from June 29th.

The preliminary solution for me was to print to a file with Elsterformular.
Please note that you currently can't choose name or path of the file. It is
always called "FILE:" (including the colon), and it is always placed in the
directory of the printing application. In your case this should be
~/.wine/drive_c/Programme/ElsterFormular2005/ or similar.
The file is in postscript format and can be printed with konqueror or lpr.

These are the steps that worked for me. They are circumstantial, but they
worked for me.

Configuring wine:

- Start with a clean ~/.wine (mv .wine .wine_backup)
- Don't use winetools
- Don't use winetools
- Run winecfg in a xterm to create your new ~.wine (maybe wincfg will print
out some warnings about printer problems and missing AFM files. Ignore
that, or run winecfg after configuring your printer)

Configuring your printer:

- Wine comes with a printer file called generic.ppd. Copy it to your cups
cp /usr/share/wine/generic.ppd /usr/share/cups/model/generic.ppd
(change the paths if necessary)
- make sure you have a local cupsd running. Using a remote cupsd doesn't
work with wine. At least it didn't work for me. If you already have a local
cupsd running, make sure to restart it.
- Add a new printer, e.g. wineprinter, and configure it to use the
generic.ppd. On the pagee "Hersteller" choose "Postscript", on the
page "Modell" choose "Generic postscript printer(en)"
- Test your printer configuration by running "wine notepad" and try to print
a sample text file. Remember to choose "Print to file". Check if the
file "FILE:" was generated.

Install Elsterformular:
Since you already used ElsterFormular, the files
ElsterFormular2005-Setup.exe, Jet40SP8_9xNT.exe, dcom98.exe and
MDAC_TYP.EXE should be at hand, along with the basic Microsoft true type
fonts (arial, andale trebuchet, verdana, etc.). If you used winetools to
install them, they are probably in ~/winetools/.

You don't need winetools to install these files. Just use wine on the
command line.

- Copy the files to ~.wine/drive_c/
- cd ~.wine/drive_c/
- wine dcom98.exe
- wine fontfile.exe (arial, andale trebuchet, verdana, etc.)
- wine MDAC_TYP.EXE (yes, it must be installed twice. Don't ask me why)
- wine Jet40SP8_9xNT.exe
- wine ElsterFormular2005-Setup.exe

If all went well, this should be it.

I hope, I didn't forget anything.

Sven Rudolph

P.S. Bisschen spät für die Steuererklärung, was? Aber die erinnern einen
schon dran...

> Hello out there,
> perhaps anybody has some idea for my problem.
> I've had several nice successes with WINE.  GoogleEarth e.g. or some of
> my old tools of the windows-times.
> Now yesterday I've sent my tax-declaration (in Germany: ElsterFormular)
> to the tax-administration, online. BUT: I couldn't print the
> declaration!! NOTHING at all happened.
> I havn't ever tried to print, it was not necessary.
> I tried several applications, and a print-form appeared. It showed my
> LINUX-Printer with its name. But I could never open the
> properties-form; in one case the application quit, when I fixed the
> portrait-format. I wasn't told, what was missing.
> I use WINE 0.9.7 and WINETOOLS 0.9 with KANOTIX 2005-4.
> My beloved printer is the hp 600.
> Greetings from Wuppertal,
> Klabauter

More information about the wine-users mailing list