[Wine] Re: com ports

Mike Anthony moravian_knight at yahoo.com
Thu Jul 13 12:37:29 CDT 2006

Nikolas Arend wrote:
> Ian Couchman wrote:
> > Hi everyone,
> > I am in the last stages of converting my business to Linux. All software is
> > now open-source or running under wine. Except one. The software supplied by
> > my bank. This runs fine under wine apart from the dialup to the bank. No
> > matter what settings I use for the modem, I always get the message that the
> > modem cannot be initialised.
> > Here's what I have confirmed so far:
> > The com port is pointing to the right place in wine. If I select a
> > non-existant port, the software says it cannot access the port.
> > I have access permissions for the port. Using kppp, I can dial out without
> > problem.
> > For the same reason, the modem, serial connections & phone connections are OK.
> >
> >
> This is just a quick shot...
> I had the same problem talking to my modem on the COM port with
> wine-0.9.16 (although I knew that it had worked before). Downgrading to
> wine-0.9.10 in my case solved the issue. I can't tell you what changed
> or at which exact version things broke. I just saw that wine 0.9.17 is
> out, maybe the issue got resolved (if there was one with 0.9.16).
> Of course, downgrading wine might bring up problems with your other
> apps, but it might be worth a try. In any case you should back up your
> ~/.wine directory before playing around ;-)
> Cheers,   Nick.

This is interesting. I have been pulling my hair out trying to get the
comm ports to work using wine and an amateur radio application. I'm
using 9.16 on a new clean SuSE 10.1 installation. Comm ports have been
chmodded to 0666 and can be communicated with outside of wine.
Soooo, does this mean somthing is broken with 9.16?

More information about the wine-users mailing list