[Wine] com ports

Ian Couchman i.couchman at shirecontrols.com
Fri Jul 14 12:54:44 CDT 2006

Tried that. Still not working. Also tried reverting to wine-0.9.10. Still no 
go. Tried a different modem (known to work with this app under windows) Still 
no go. I did notice that the tr & rs lamps on the modem came on while the app 
was trying to initialise the modem. Does that give anyone a clue?
On Thursday 13 July 2006 19:16, CptDondo wrote:
> Ian Couchman wrote:
> > Hi everyone,
> > I am in the last stages of converting my business to Linux. All software
> > is now open-source or running under wine. Except one. The software
> > supplied by my bank. This runs fine under wine apart from the dialup to
> > the bank. No matter what settings I use for the modem, I always get the
> > message that the modem cannot be initialised.
> > Here's what I have confirmed so far:
> > The com port is pointing to the right place in wine. If I select a
> > non-existant port, the software says it cannot access the port.
> > I have access permissions for the port. Using kppp, I can dial out
> > without problem.
> > For the same reason, the modem, serial connections & phone connections
> > are OK.
> >
> > The software asks for the following information for modem setup:
> > Modem type
> > Com port
> > Baud rate
> > Initialisation string
> > Start of call string
> > End of call string
> > Termination string
> > I have used the pre-set options for a standard modem.
> >
> > I am running wine-0.9.16 on debian sarge.
> > Any help would be much appreciated. (does anyone know how to find out
> > what windows sends to a com port?)
> Google Groups for 'serial port woes' by me (CPtDondo).  I had a similar
> problem and posted a hack (not really a solution) to CVS that allowed me
> to get my serial ports working.

More information about the wine-users mailing list