[Wine] Wine cannot launch "child" applications

Leigh Wedding leigh.wedding at telstra.DELETE-this.com
Fri Jun 2 06:00:19 CDT 2006

I have a problem that Wine cannot launch "child" applications,Here is
what I mean.

I can run applications directly using wine at the command line, eg:

        wine reversi.exe

works fine.  But if I try to run the same application via winefile by
browsing to the directory and then double clicking the application,
then I get an error message: "File not found".  Also I get the same
problem trying File -> Run in winefile.

Similarly, if I run an installation executable which extracts a number
of files, and then needs to run an extracted executable, it also fails
to run the extracted executable.  For example, if I try to install
arial32.exe fonts package by running "wine arial32.exe", that
executable runs okay and extracts the files to
"C:\windows\temp\IXP000.TMP", but then I get the error message:

    "Error creating process <C:\windows\temp\IXP000.TMP\FONTINST.EXE>.
    Reason: File not found".

However if I actually go to that directory, and run it with

    "wine FONTINST.EXE"

then it works perfectly!  Running: wine
"C:\windows\temp\IXP000.TMP\FONTINST.EXE" also works.

Also if I try to install MS Office 2000, I get a similar problem about
cannot find msiexec.exe, but if I run manually run

    msiexec /i DATA1.MSI

then it does do some things, but then seems to run into the same
problem recursively again of trying to launch further extracted

This looks like a pretty simple path and/or library lookup problem,
but I just can't figure it out.

Any clues to how to fix it?  Any more info required?

I have wine 0.9.14, but the problem also occurred in 0.9.13, and a few 
previous versions I tried.
I am running Slackware 10.1
kernel 2.6.16

I am trying to run wine compiled by myself, as the latest precompiled
binaries are for Slackware 10.2.

Leigh Wedding

More information about the wine-users mailing list