[Wine] Re: Wine : error during compilation (mandriva 2006 - x86_64)

Dan Espen daneNO at MORE.mk.SPAMtelcordia.com
Sat Jun 3 10:03:45 CDT 2006

sebas <sebas at nospam.invalid> writes:

> Hi,
> I have Mandriva 2006 x86_64.
> I tried to install wine, but the binaries are for 32 bits and the result
> is very instable (win programs close suddenly, no internet available for
> those programs, etc...)
> So I tried to compile wine 0.9.14 from source, but I have an error
> during make when "searching for -lXext" : 
> LD_LIBRARY_PATH="../../libs/unicode:$LD_LIBRARY_PATH" ../../tools/wrc/wrc
> --nostdinc -I. -I. -I../../include -I../../include -I/usr/X11R6/include
> -D__WINESRC__   -foversion.res version.rc ../../tools/winegcc/winegcc
> -B../../tools/winebuild -shared ./ddraw.spec
>  clipper.o ddraw_hal.o ddraw_main.o ddraw_thunks.o ddraw_user.o
> ddraw_utils.o main.o palette_hal.o palette_main.o regsvr.o surface_dib.o
> surface_fakezbuffer.o surface_gamma.o surface_hal.o surface_main.o
> surface_thunks.o surface_user.o surface_wndproc.o  version.res
> -Wl,--rpath,\$ORIGIN/`../../tools/relpath /usr/local/lib/wine
> /usr/local/lib` -o ddraw.dll.so -L../../dlls -lole32 -luser32 -lgdi32
> -ladvapi32 -lkernel32 -lntdll  -L../../libs -lwine -ldxguid -luuid
> -L/usr/X11R6/lib64  -lXext -lX11   -L../../libs/port -lwine_port
> /usr/bin/ld: skipping incompatible /usr/X11R6/lib64/libXext.so when
> searching for -lXext /usr/bin/ld: cannot find -lXext collect2: ld returned
> 1 exit status
> winegcc: gcc failed.
> make[2]: *** [ddraw.dll.so] Erreur 2
> make[2]: Leaving directory
> `/home/alvi/Téléchargement/wine-0.9.14/dlls/ddraw' make[1]: *** [ddraw]
> Erreur 2
> make[1]: Leaving directory `/home/alvi/Téléchargement/wine-0.9.14/dlls'
> make: *** [dlls] Erreur 2
> What should I do to resolve this ?

If you don't have /usr/X11R6/lib/libXext.so you should install it.
If you do have it, you need to know what flags to pass to the compiler
to use it.

> Is there somebody who manage to use wine under x86_64 ?

According to Google, 32 bit wine works fine.

> Why all internet options are not available under wine, while linux
> programs access it normally ?

I find your problem description "all internet options are not available"
incomprehensible.  If you want to solve the problem, you need to
describe it better.

More information about the wine-users mailing list