[Wine] Re: VDQ : Have I made a wine's nest? -- Update

Beartooth beartooth at adelphia.net
Fri Mar 10 11:37:49 CST 2006

On Fri, 10 Mar 2006 08:42:38 -0800, Duane Clark wrote:

> Beartooth wrote:
>> Why is it claiming 20 and only showing me six?
> Ignore that. I don't know what the number means when the 'L' parameter 
> is used with 'ls', but it doesn't mean there are actually 20 entries. 
> Try the ls without the 'L' and see the difference. 
>> More disturbingly, what is that next to last line with all the question
>> marks?? Have I messed up my dosdevices? 

> When using the 'L' parameter, that appears to indicate an invalid link.

Sure enough : 

[btth at localhost dosdevices]$ ls
c:  com1  com2  z:
[btth at localhost dosdevices]$ file com1
com1: symbolic link to `/dev/ttyS0'
[btth at localhost dosdevices]$ file com2
com2: broken symbolic link to `/dev/ttyUSB0'
[btth at localhost dosdevices]$

NB: com2, but not com1, shows up on a red background on my screen, which
is what prompted me to try the file command. And I found confirmation --
of a sort : 

[root at localhost ~]# ls /dev/ttyS*
/dev/ttyS0  /dev/ttyS1  /dev/ttyS2  /dev/ttyS3
[root at localhost ~]# ls /dev/ttyU*
ls: /dev/ttyU*: No such file or directory
[root at localhost ~]# 

Being a skeptical sort, I also tried ls /dev/tty* -- and sure enough,
there is no /dev/ttyU-anything. Yet the machine has two USB ports right in

BUT when I do [root at localhost ~]# ls /dev | grep tty I do get a bottom
line saying ttyUSB0 -- what in ....??

Incidentally, I also get 

[root at localhost ~]# file /dev/ttyUSB0
/dev/ttyUSB0: character special (188/0)
[root at localhost ~]#

which appears quite analogous to the results for tty, tty1, etc.

I plugged the adapter that goes between a serial cable and a USB port into
one, did /dev/ttyU* again, and got the same again, on both. So I tried it
again, with the serial cable and a live GPS on the adapter. Still none.

Do I need to add a couple of lines to /dev/? Can I simply command "nano -w
/dev" and type onto the bottom? Or What?? Why isn't the machine seeing it
own hardware, that's been there since I got it, months ago? Or seeing it
one way, but not another??

Beartooth Staffwright, PhD, Neo-Redneck, Double Retiree,
Not Quite Clueless Linux Power User : Fedora Core 4 [etc]
I have precious (very precious) little idea where up is.

More information about the wine-users mailing list