[Wine] Unable to configure wine

L. Rahyen research at science.su
Mon Aug 6 17:36:11 CDT 2007

On Monday August 6 2007 20:40, Roel Schroeven wrote:
> Sorry for the uninformative subject line; I can't think of a short way
> to describe the problem.
> I installed Wine on a Debian Sarge machine. I installed Wine version
> 0.9.25 from backports.org, since the version in Sarge proper is way too
> old.
> Then I tried to configure Wine using winecfg, but that didn't work out:
> I only got this output (abbreviated; I can send the full output if
> anybody is interested):
> Invoking /usr/lib/wine/wine.bin winecfg.exe ...
> wine: creating configuration directory '/home/roel/.wine'...
> wine: Unhandled page fault on write access to 0x003ffd80 at address
> 0x608937fe (thread 000b), starting debugger...
> wine: Unhandled page fault on write access to 0x003ffd80 at address
> 0x608937fe (thread 000d), starting debugger...
> Unhandled exception: page fault on write access to 0x003ffd80 in 32-bit
> code (0x608937fe).
> Register dump:
>   CS:0023 SS:002b DS:002b ES:002b FS:1007 GS:0000
>   EIP:608937fe ESP:0034eb68 EBP:0034eec0 EFLAGS:00010216(   - 00
> -RIAP1)
>   EAX:0034efe0 EBX:6089ad00 ECX:60016ca0 EDX:003fffff
>   ESI:003ffd80 EDI:60016540
> Stack dump:
> 0x0034eb68:  0034eb98 60898dd0 0034eb98 0034eb94
> 0x0034eb78:  00000000 00000000 00000004 00000003
> 0x0034eb88:  60899f18 60899f14 0034ee1c 00000023
> 0x0034eb98:  53203123 5720504d 41206465 31206775
> 0x0034eba8:  30312037 3a35303a 55203132 32204354
> 0x0034ebb8:  00353030 00000005 00001000 00000001
> 0200: sel=1007 base=7ffdc000 limit=00001fff 32-bit rw-
> Backtrace:
> =>1 0x608937fe pthread_initialize+0x23e in libpthread.so.0 (0x0034eec0)
>    2 0x60898d45 __do_global_ctors_aux+0x35 in libpthread.so.0 (0x0034eed0)
>    3 0x6088fc6a _init+0x12 in libpthread.so.0 (0x0034eed8)
>    4 0x6000c1ce in ld-linux.so.2 (+0xc1ce) (0x0034ef08)
>    5 0x6000c36a _dl_init+0x15a in ld-linux.so.2 (0x0034ef48)
>    6 0x60236092 in libc.so.6 (+0x107092) (0x0034efb8)
>    7 0x6000c016 _dl_catch_error+0x76 in ld-linux.so.2 (0x0034f0b8)
>    8 0x60236676 _dl_open+0x66 in libc.so.6 (0x0034f118)
>    9 0x60263008 in libdl.so.2 (+0x1008) (0x0034f128)
>    10 0x6000c016 _dl_catch_error+0x76 in ld-linux.so.2 (0x0034f228)
>    11 0x602634c6 in libdl.so.2 (+0x14c6) (0x0034f258)
>    12 0x60263054 dlopen+0x34 in libdl.so.2 (0x0034f278)
>    13 0x6001e9e6 wine_dlopen+0x36 in libwine.so.1 (0x0034f2a8)
>    14 0x606df8f5 in winex11 (+0x2f8f5) (0x0034f2d8)
>    15 0x606e607e X11DRV_setup_opengl_visual+0x5e in winex11 (0x0034f388)
>    16 0x606f7797 in winex11 (+0x47797) (0x0034f3c8)
> I've googled around a bit, and I've seen many questions about a similar
> problem, but no solutions. Some people say it's a problem with the 2.4
> kernel (the machine is running 2.4.27-2-686-smp) and/or glibc (we're
> running 2.3.2.ds1-22sarge6 on that machine). However, the FAQ on the
> Wine webpage doesn't mention anything about problems with either of these.
> I tried to install Wine on a system with a newer Debian (etch); there I
> could configure it without problems.
> I'd rather not upgrade from sarge to etch on this machine, so I hope
> there are solutions besides that.

	There is only two options for you if you don't want to upgrade. First, you 
can try to compile WINE yourself and see if it helps. And second, you can try 
to use ancient WINE versions (as old as your distro); drawback of this option 
I think is obvious.
	But I personally recommend you to upgrade your Debian. In fact, I see no 
reason why not to upgrade even if machine in question is old and slow. Etch 
is a lot better than Sarge. At least I like it much more.

More information about the wine-users mailing list