[Wine] Errors compiling wine under Red Hat

Walter Graf grafw at umich.edu
Tue Aug 7 07:48:51 CDT 2007

Hello, all,
I'm trying to get Wine running on some Red Hat boxes at my University (don't
worry, I have permission!) ... But, I don't have any root access to the
boxes, and I'm limited to installing on my shared (AFS) space. In any case,
I'd probably want it to run from my user space anyways, so that its
accessible from all boxes on the network.
Some required information, probably:

dc3nep68% cat /proc/version
Linux version 2.6.9-42.0.10.ELsmp (brewbuilder at ls20-bc1-14.build.redhat.com)
(gcc version 3.4.6 20060404 (Red Hat 3.4.6-3)) #1 SMP Fri Feb 16 17:13:42
EST 2007

When I log in, it greets me with:
CAEN Red Hat Enterprise Linux WS release 4 (Nahant Update 4)

I know, these boxes are pretty old. There's not much I can do about that.
I tried to do an RPM install using --prefix=[somewhere in my AFS user
space], but it tells me "wine is not relocatable." (I very well may have
done something wrong, as I'm not a RH guy. If anyone has suggestions on this
front, I'd gladly accept them, too!) So, I figured I'd have a go at
compiling. So,

./configure --prefix=[a folder in my AFS space] --without-opengl
goes fine

make depend
no problems

goes ok for a bit, then (starting form the topmost error I can find):

gcc -m32 -c -I. -I. -I../../include -I../../include
-DAS="\"as --32\"" -DCC="\"gcc -m32\"" -DCPP="\"cpp\"" -DCXX="\"g++\""
-DLD="\"ld -m elf_i386\"" -DPRELINK="\"/usr/sbin/prelink\""  -Wall -pipe
-fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings
-Wpointer-arith  -g -O2  -o winegcc.o winegcc.c
cc1: error: invalid option `32"'
cc1: error: missing argument to "-m"
cc1: error: unrecognized command line option "-f32""
make[2]: *** [winegcc.o] Error 1
make[2]: Leaving directory `/afs/engin.umich.edu/u/g/r/grafw/Private/wine-
make[1]: *** [winegcc] Error 2
make[1]: Leaving directory `/afs/engin.umich.edu/u/g/r/grafw/Private/wine-
make: *** [tools] Error 2

I've tried compiling with several versions of Wine (the exact error above is
from 0.9.42, but I also got the same thing with 0.9.41 an 0.9.12)...
That's about it. Does anybody know what's going on here? Do I need to give
any other information?

Thanks :D

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.winehq.org/pipermail/wine-users/attachments/20070807/1702a8dd/attachment.htm

More information about the wine-users mailing list