[Fwd: Re: [Wine] Dead keyboard]

Jose Young young7 at ciudad.com.ar
Tue Aug 7 14:35:45 CDT 2007


Well, I found that when wine installed Windows, it did not install the 
"standard" fonts, like Ariel or Times. So when I copied them to the wine 
version of Windows, the "hunt for fonts" was reduced to two... and I 
know which they are, so eventually...  Anyway, that problem cleared up.

But one more thing. I now start the program from the terminal with two 
lines of code that L. Rahyen sent me. Is there a way to put that into 
the Applications list, or even make a "button" that would run it? This 
method is pretty awkward.

Thanks for any suggestions


Running the program in a Wine Desktop solves the keyboard problem, and 
the program seems to be working normally.

But there is still an item that I do not understand. When I load the 
program, in the Terminal appear a series of something like 15 lines like 
this one: 


Then when I close the program the same number of this line appears:

fixme:font:WineEngRemoveFontResourceEx :stub

The loading is very slow, because of those beginning processes. I can 
see that they have to do with fonts, but is it a problem of Windows 
fonts, or fonts of the program that I run? Would installing fonts be a 
solution, but how to know which ones and where?

Any help on this one would be very appreciated.


> By definition if you cannot access it you cannot run programs from it. But 
> you of course can.
> 	First, if you want to convert Windows path to UNIX path run something like 
> this:
> winepath "C:\Program Files\Corel\Ventura 10/Programs/ventura.exe"
> 	And you will get the output (it may vary for your system but if you didn't 
> tweak WINEPREFIX environment variable it will be very similar to example 
> below; "~" means your home directory):
> ~/.wine/dosdevices/c:/Program Files/Corel/Ventura 10/Programs/ventura.exe
> 	As you can see you always always can to cd to your virtual C:\ drive and do 
> whatever you want with its files or subdirectories.
> On Monday August 6 2007 23:47, Jose wrote:
>> So I ran the program, and wrote something without opening a data file.
>> Here is the result:
>> jose at josey:~$ wine  "C:\Program Files\Corel\Ventura
>> 10/Programs/ventura.exe" Fontconfig error: "~/.fonts.conf", line 2: not
>> well-formed (invalid token) Fontconfig error: "~/.fonts.conf", line 2: not
>> well-formed (invalid token) err:x11drv:X11DRV_CreateWindow invalid window
>> height -25
>> fixme:mmio:MMIO_InstallIOProc Global procedures not implemented
>> I I write, it comes out here.
>> So the keyboard works, but it works in the Terminal window. Don't know
>> if this will be of help to start off with.
> 	Please read http://bugs.winehq.org/show_bug.cgi?id=1798 ; you probably want 
> to mention there that your program doesn't work out-of-the-box.
> 	Here is few hints:
> 	Try this (just copy/past these two lines to you X terminal):
> cd "`winepath 'C:\Program Files\Corel\Ventura 10/Programs/'`"
> wine explorer /desktop=Ventura_10,800x600 ventura.exe
> 	...And see if it helps.
> 	You can replace "Ventura_10" with any name you like (this is uniq ID for 
> virtual desktop). And of course you can adjust the resolution of your virtual 
> WINE desktop as necessary.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.winehq.org/pipermail/wine-users/attachments/20070807/0e237687/attachment.html

More information about the wine-users mailing list