[Wine] Errors compiling wine under Red Hat

Bryan DeGrendel sirnuke at gmail.com
Tue Aug 7 21:43:35 CDT 2007

On 8/7/07, Walter Graf <grafw at umich.edu> wrote:
> Hello, all,
> I'm trying to get Wine running on some Red Hat boxes at my University (don't
> worry, I have permission!) ... But, I don't have any root access to the
> boxes, and I'm limited to installing on my shared (AFS) space. In any case,
> I'd probably want it to run from my user space anyways, so that its
> accessible from all boxes on the network.
> Some required information, probably:
> dc3nep68% cat /proc/version
> Linux version 2.6.9-42.0.10.ELsmp
> (brewbuilder at ls20-bc1-14.build.redhat.com) (gcc version
> 3.4.6 20060404 (Red Hat 3.4.6-3)) #1 SMP Fri Feb 16 17:13:42 EST 2007
> When I log in, it greets me with:
> CAEN Red Hat Enterprise Linux WS release 4 (Nahant Update 4)
> I know, these boxes are pretty old. There's not much I can do about that.
> I tried to do an RPM install using --prefix=[somewhere in my AFS user
> space], but it tells me "wine is not relocatable." (I very well may have
> done something wrong, as I'm not a RH guy. If anyone has suggestions on this
> front, I'd gladly accept them, too!) So, I figured I'd have a go at
> compiling. So,
> ./configure --prefix=[a folder in my AFS space] --without-opengl
> goes fine
> make depend
> no problems
> make
> goes ok for a bit, then (starting form the topmost error I can find):
> gcc -m32 -c -I. -I. -I../../include -I../../include
> -DINCLUDEDIR="\"/afs/engin.umich.edu/u/g/r/grafw/Private/wine/include/wine\""
> -DDLLDIR="\"/afs/engin.umich.edu/u/g/r/grafw/Private/wine/lib/wine\""
> -DLIBDIR="\"/afs/engin.umich.edu/u/g/r/grafw/Private/wine/lib\""
> -Wl,-Bsymbolic,-z,defs,-init,__wine_spec_init,-fini,__wine_spec_fini\""
> -DAS="\"as --32\"" -DCC="\"gcc -m32\"" -DCPP="\"cpp\"" -DCXX="\"g++\""
> -DLD="\"ld -m elf_i386\"" -DPRELINK="\"/usr/sbin/prelink\""
>  -Wall -pipe -fno-strict-aliasing -Wdeclaration-after-statement
> -Wwrite-strings -Wpointer-arith  -g -O2  -o winegcc.o winegcc.c
> cc1: error: invalid option `32"'
> cc1: error: missing argument to "-m"
> cc1: error: unrecognized command line option "-f32""
> make[2]: *** [winegcc.o] Error 1
> make[2]: Leaving directory
> `/afs/engin.umich.edu/u/g/r/grafw/Private/wine-0.9.42/tools/winegcc'
> make[1]: *** [winegcc] Error 2
> make[1]: Leaving directory
> `/afs/engin.umich.edu/u/g/r/grafw/Private/wine-0.9.42
> /tools'
> make: *** [tools] Error 2
> I've tried compiling with several versions of Wine (the exact error above is
> from 0.9.42, but I also got the same thing with 0.9.41 an 0.9.12)...
> That's about it. Does anybody know what's going on here? Do I need to give
> any other information?
> Thanks :D
> Walter
> _______________________________________________
> wine-users mailing list
> wine-users at winehq.org
> http://www.winehq.org/mailman/listinfo/wine-users

Hello.  I spend some time get a half-decent music player to compile on
my AFS space a few months ago.  A few notes:

1. I believe all CAEN computers are 64-bit.  -m32 flag means compile a
32-bit program for a 64-bit OS, if I understand correctly.  It looks
like you need the glibc-devel 32-bit package for that to work [1].
2. There weren't many dev libraries installed on the box I was on.  I
guess if ./configure ran okay there aren't any show stopping problems,
but you might want to try the --verbose flag to see what you are

I don't have any experience with WINE on 64-bit but you might want to
read this [2] page.

Good luck,
Bryan DeGrendel

[1] http://www.redhat.com/archives/fedora-devel-list/2005-January/msg00831.html
[2] http://wiki.winehq.org/WineOn64bit

More information about the wine-users mailing list