[Wine] Serial Woes

Declan Moriarty junk_mail at iol.ie
Mon Feb 19 05:34:57 CST 2007

On Sun, 2007-02-18 at 15:13 -0800, Larry Lohkamp wrote:
> Hash: SHA1
> My setup is the standard one generated by the Suse RPM.  The links in
> the dosdevices directory for hardware access are owned by root, and
> locked to ordinary users. I can su to root and change the permissions.
> This allows my programs to access the serial ports, but it is not
> persistent. On reboot, the links are again locked. I tried deleting
> the links and creating new ones as the ordinary user. Again, this is
> not persistent. On reboot, root again seizes control of the links and
> locks out other users. Since I am the administrator of this machine, I
> can kludge my way around it by changing the permissions every time I
> start up the computer, or I can be stupid and run everything as root.
> Neither is a spiffy solution. If you know where in the startup scripts
> root is making a nuisance of himself, I appreciate enlightenment on
> fixing it.
> Larry
> Uwe Bonnes wrote:
> >>>>>> "Larry" == Larry Lohkamp <loko at comcast.net> writes:
> >>>>>>             
> >
> >     Larry> I have been trying to throw away my dependence on Windoz
> since
> >     Larry> the early Pentium era, but there always seems to be some
> >     Larry> essential application that can't be replaced. Currently
> it is the
> >     Larry> programs that read my blood glucose meeter and an
> athletic
> >     Larry> trainer system. Both of them communicate through a serial
> port. I
> >     Larry> am currently working on getting the trainer going. It
> loads fine
> >     Larry> and has no trouble running until it tries to connect to
> the
> >     Larry> hardware. I get a program error saying that it cannot
> find the
> >     Larry> trainer. I seem to have the link that points wine to the
> serial
> >     Larry> port device, but the terminal screen fills with 'handle
> not
> >     Larry> found' errors when the connection is attempted. Surely,
> after all
> >     Larry> the work that has gone into wine, someone has gotten the
> serial
> >     Larry> ports to work.
> >
> > I suspect that your setup is wrong. Either the serial port has
> inappropriate
> > permissions or the link in dosdevices is wrong.
> >
> > I suggest you should learn some basic wine debugging. Run with e.g.
> with
> > WINEDEBUG=+relay, pipe the resulting output into a file and
> afterwards grep
> > through the file to find the place where the application tries to
> open the
> > serial port. Try to find out what goes wrong and fix your setup.

This sounds like a linux issue, not a wine one.

Symlink permissions are normally 0777 which means it doesn't matter who
owns them.
The permissions you may want to look at are in /etc/udev, where the
symlink nodes are created each boot, and they might well use the group
uucp, a dinosaur from the dialup days. Have you tried getting your wine
user into that? Alternatively you can twiddle the settings in /etc/udev,
(_if_ you can find them), and the nodes are created to your spec each
reboot. This line from /etc/rules.d/50-udev.rules looks promising from a
Fedora system, but really, I'm guessing.

KERNEL=="tty[A-Z]*",            NAME="%k", GROUP="uucp", MODE="0660"

The theory is - if you join group uucp, you can write there. If not, you
can't even read the port. 

Declan Moriarty <junk_mail at iol.ie>

More information about the wine-users mailing list