[Wine] Using OLE DB Connections from Wine

Tomasz Czapiewski xeros at telesat.com.pl
Wed Feb 21 04:13:52 CST 2007

Edward Costello wrote:

> Hi,
> I'm trying to use Enterprise Architect under wine. According to their 
> documentation it runs on "Codeweavers Crossover" so I believe it
> should also run under wine (it's listed as basically working in the 
> application DB http://appdb.winehq.org/appview.php?iVersionId=6018
> ( http://appdb.winehq.org/appview.php?iVersionId=6018 ) ).
> I'm trying to get an OLE connection to a central database server. I 
> suspect that in order to do this I need to use the native DCom
> DLL's. However every time I attempt to install them into wine using the 
> installer I down loaded from Microsoft I get a message saying
> that a newer version is already installed.
> Does anyone know how to do this without using winetools?
> Cheers
> Ed

I'm using Enterprise Architect under wine - it's works fine and stable 
(both trial and full version) and I've done there some projects for 
students work at university.
I don't remember exactly what I did but I followed the instruction from 
EA site about running it on CrossOver Office but not everything was 
needed because wine has already good builtin replacements for some Windows 
components (I'm not 100% sure but I think I used wine's builtin DCOM). I 
didn't use winetools, wine wiki was very helpfull.
(I remember only that I have installed MDAC and setup Windows ODBC for 
other apps the same time I used EA).
The wine version I used to install it was something from 0.9.26 to 0.9.28 
- don't remember, but after every upgrade (to 0.9.30 now) it works.

:  `Yg. ,P' ,gP""Yg. gP""Yg. ,gP""Yg. ,gP""Yg   :   Tomasz Czapiewski    :
:   `Y$B'   $P   ,$' $$   YP d'   `Y$ `Y._      :      xeros at irc.pl      :
:    ,PY$.  Y$.-"`   Y$ _,P' $b.   ,P   `""Yg.  :     ICQ: 109320380     :
:  ,P'  `Y$.`Yg._.:' :$ `s._ `Yb._,P' `Y.__,P"  :      GG: 1578983       :

More information about the wine-users mailing list