[Wine] Error running Guild Wars with .9.3

Guillaume Vachon gvachon at tc2l.ca
Tue Jan 30 14:05:10 CST 2007

I had the same probleme. I had to run it in a windows mode to get it 
started the first time. Then, you can put it back to full screen and you 
wont get that error anymore. The only other issue I've had is when 
changing zone. I loose my mouse point do a few right click and it comes 

I hope this will help you

Guillaume Vachon
Administrateur Système
Techno Centre Logiciels Libres, http://www.tc2l.ca/
Téléphone : (418) 681-2929 poste 123

Eatherington Philip a écrit :
> Hello all,
> I gave this a stab a few months ago but gave up and
> just set up a dual boot.  I'm running low on disk
> space now and tired of messing with the muliple
> partitions, so I'm giving it another go to get Guild
> Wars running in Linux.
> I'm runing Wine 0.9.3 on Kubuntu 6.06 (Dapper Drake). 
> I'm able to go through the instillation without issue,
> but when it actually tries to launch the game, I get
> the error message form Guild Wars:
> "Unable to initialize 3D output.  Please verify that
> you have installed DirectX8 and an updated video
> driver.  Click the URL below to open a web page with
> more information.
> http://www.guildwars.com/support/en-3dinitializationerror.php"
> I'm running the command /pathtoGuildWars/wine Gw.exe
> -dx8 -noshaders as I found this at the Wine HQ app db.
>  I've tried searching the archive and the web but
> don't seem to be able to find anyting on this
> particular issue - I'm ready to accept that once I get
> past this, there will be other issues that may not be
> solvable right now, but it seems weird that nobody
> else has had this error enough to even find three
> relevant hits.
> When I run it from the command line, the shell fills
> up with more information than the screen can hold -
> almost all of it I can see is items saying things like
> the following:
> fixme:dxdiag:IDxDiagContainerImpl_AddProp (0x1aa160,
> L"szClsidFilter", 0x34f2e4)
> fixme:dxdiag:IDxDiagContainerImpl_AddProp (0x1aa160,
> L"szName", 0x34f2d4)
> fixme:dxdiag:IDxDiagContainerImpl_AddProp (0x1aa160,
> L"dwMerit", 0x34f2d4)
> fixme:dxdiag:IDxDiagContainerImpl_AddProp (0x1aa160,
> L"dwInputs", 0x34f2d4)
> fixme:dxdiag:IDxDiagContainerImpl_AddProp (0x1aa160,
> L"dwOutputs", 0x34f2d4)
> So I'm guessing it is my DirectX somehow. I have also
> tried it without the -dx8 flag.
> Any insight is appreciated!
> ____________________________________________________________________________________
> The fish are biting. 
> Get more visitors on your site using Yahoo! Search Marketing.
> http://searchmarketing.yahoo.com/arp/sponsoredsearch_v2.php
> _______________________________________________
> wine-users mailing list
> wine-users at winehq.org
> http://www.winehq.org/mailman/listinfo/wine-users

More information about the wine-users mailing list