[Wine] Re: Wine and MS Access problem

Robert McLean robert.mclean1 at sympatico.ca
Mon Mar 19 00:49:15 CDT 2007

Daniel Skorka wrote:
> Robert McLean <robert.mclean1 at sympatico.ca> wrote:

some snipping

> > In the Wine configuration screen under drive mappings I have
> > C:   /mnt/windows/C/
> Do _not_ do that. Unless you have important data in it, delete ~/.wine
> Leave the mapping of C: alone (i.e. keep it at ~/.wine/drive_c. C is
> where wine expects to find DLLs and stuff.

OK, I dont fully understand that, but I gave it a try.  I deleted
~/.wine  (well actually I renamed it to wine_backup, just in case I
want to change my mind )

I went into Wine Configurations and it was starting off fresh, with
just a c drive at ../drive-c and one ohter Z or H, I dont recall now.

I want a D drive somewhere so I hit auto detect.  I got
c:   ../drive_c
D:  /mnt/windows/C
E:  /mnt/windows/D
H:  /home/Bob
Z:  /

I didnt understand why D: was mapped to /mnt/windows/C, or why E: was
mapped to D, but i thought maybe the machine knows better than me, so I
tried running wine with those settings.  But I got error message about
not finding the program file on D.  Obviously since it is looking for D
files on C.
So I changed the setting for D: to /mnt/windows/D. I left C as it was
as you suggest as ../drive_c.

So I try wine with my spice program scad3.exe, and with msaccess.

With scad3 it launches, and mostly works.  When I hit the open file
command I can browse a directory tree as one  would expect, and I can
see files on D, and I can see files on C where they belong.  So it is
seeing C drive from that point of view.  But when I try to do a circuit
simulation, it is necessary for the program to look up "include" files,
and these are on my C drive.  It doesnt find them.    It does find
them, and the program works perfectly, when I have the Wine
configuration set to C:  /mnt/windows/C

When I run wine with msaccess I get the same DLL not found message.  So
based on wine documentation suggestion, I copied the msjet35.dll into
the same folder as the executable, msaccess.exe.  Now when I run wine
and access, the dll not found message is not produced.  I get a
different error instead.   It works the same way wether I have C:
../drive_c  or C:  /mnt/windows/C

> > right, So I went into config and mapped C into where it is actually
> > mounted.
> Well, you were wrong. What you never should do is something like
> $ wine /path/to/app.exe

But I didnt do anything like that.  Perhaps the term mapping is
incorrect.  All I did was go into wine config and set C: to
/mnt/windows/C  , in other words set it to where it is actually mounted
in linux

> Instead, do
> $ cd /path/to && wine app.exe
> This solves most file not found problems. If that doesn't help, well
> have to keep looking.

OK, what I did was try to figure out where my wine executables are.
Being new to linux, I am not sure if I have found them.  I see in
/usr/lib/wine a lot of files with extensions .dll.so and .exe.so  From
what I can gather .so means they are shared files.  The file types
given in the File Browser doesnt actually call any of the files I can
find applications, or executables or any term like that.  So have I
found the right folder ?
In any case I tried cd /use/lib/wine, got to the folder in question,
and then ran wine, but the results were the same.

> For general reference, you should read the Wine Users Guide:
> http://winehq.org/site/docs/wineusr-guide/index

Yes, I have done that.  Always good advice to read the manual !!

So basically where I am at now is that with the configuration C:
/mnt/windows/C  everything works the way it should with one of my
applications,  but no configuration works properly with MSAccess.  With
the configuration C:  ../drive_c  my apps dont work right.  I am sure
you have good reasons for saying to use ../drive_c, but I will use
/mnt/windows/C for now since it actually works.

The error with Access now is
"Microsoft Access can't start because there is no license for it on
this machine"
but I do have a perfectly good legal copy of access installed, it works
fine from windows.  So I will start a new thread on that problem.

thanks for your time and patience helping me with this.

> Daniel

More information about the wine-users mailing list