[Wine] Re: No License error message when running MSAccess via Wine

Robert McLean robert.mclean1 at sympatico.ca
Mon Mar 19 00:49:45 CDT 2007

Daniel Skorka wrote:

> Most likely Access is looking for a registry key that contains a serial
> number or something similar. This key exists under windows because that
> is where you installed it. Consequently, it doesn't exist in the wine
> registry. If I am right, you need to dig through the windows registry
> for this key, and add it to the wine registry.
> Daniel

Ok, I gave this a try.  I booted up windows, went into regedit, and
browsed around until I found a lot of MSOffice and Access stuff.  But
there is a whole tree of Access related items, and none of the titles
actually come right out and say "I am an installation serial number".
So I thought perhaps I should copy over the entire Access branch of
this registry tree (tree is my term, i dont know the correct one.)  and
that way I would have everything I could possibly need. Under file menu
is an entry for "Export", so I clicked on that, and save a file I
called AccessReg.reg.  When boot up Linux, I run  wine Regedit.   It
looks just like windows regedit. Under the file menu I see an entry for
"Import" so I thought that sounds like what I want.  I clicked to where
in the tree I think more or less matches where I took my access
registry stuff from, clicked on Import, it opens a browser, I find and
select my AccessReg.reg file, and say OK, but nothing happens.

Should this have worked ?
or am I being too simple minded in my interpretation of the "export"
and "import" buttons in each version of regedit ?

Am I going to have to manually add all the branches of my Access
registry tree ?

Is there some way of recognizing which subsection is the one with the
install key so that I dont have to copy all of them ?


More information about the wine-users mailing list