[Wine] Re: Wine Crashes X11

edercarneiru at gmail.com edercarneiru at gmail.com
Mon Mar 19 00:54:26 CDT 2007

On 3 fev, 18:39, "Robert M. Riches Jr." <spamtra... at verizon.net>
> On 2007-02-03, edercarne... at gmail.com <edercarne... at gmail.com> wrote:
> >  I'm using SuSE 10.2 on a x86 system. I was previously using suse 10.1
> > and wine was working fine. When I upgraded,  i could not get wine
> > working again. Everytime i try to launch it, using any windows
> > program, it simply crashes x11 and i get back to xdm login screen. I
> > can not put more info here since i don't know how to get them. Does
> > wine save any log or something like?
> My guess would be your X server and/or graphics card drivers
> are causing the X crash.  No matter what an application
> does, the X server should not crash--at least in theory.
> Check /var/log/messages and /var/log/Xorg.0.log or whatever
> your X server log file is.  There may be something there.
> One thing that might solve the crashes would be to disable
> DRI/DRM and/or other acceleration options.  Your X config
> file would be the place to make those changes.  Of course,
> make a backup copy first.
> If Suse has the option of booting to a text console rather
> than XDM, that can avoid some chicken-and-egg problems while
> playing with X config stuff.  With Redhat-related systems,
> you use runlevel 3 rather than runlevel 5 to do that, then
> use startx to start an X server.
> --
> Robert Riches
> spamtra... at verizon.net
> (Yes, that is one of my email addresses.)

In fact, the problem is on xorg. I did an online update for xorg 7.2,
and then the x server display's me just a black screen. Then i edited
xorg.conf and disabled loading of dri, glcore and glx. Now it works
fine. But image quality is less good :( I'm using a via onboard via
adapter, and it seems that the dri/drm support on it is  broken. Maybe
someday i upgrade to a really 3d card.

More information about the wine-users mailing list