[Wine] Re: Problems with wine/openSuse 10.2/Papyrus 12.56

paul williamson paul.williamson at zetnet.co.uk
Mon Mar 19 00:55:37 CDT 2007

On Fri, 02 Mar 2007 20:53:04 +0000, paul williamson wrote:

> I have recently changed from Suse 10.0 to openSuse 10.2 on my desktop PC,
> and I am having problems running the latest version of Papyrus (12.56) a
> Windows word-processor.  I can run an older version of Papyrus without
> any trouble.

No replies so far, so here's the start of the console output in the hope
someone may know where the problem lies:

fixme:system:SystemParametersInfoW Unimplemented action: 8193
(SPI_SETFOREGROUNDLOCKTIMEOUT) wine: Unhandled page fault on read access
to 0x00000018 at address 0x4ef87a (thread 0009), starting debugger...
Unhandled exception: page fault on read access to 0x00000018 in 32-bit
code (0x004ef87a). Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b EIP:004ef87a ESP:7f22eefc
 EBP:7f22ef90 EFLAGS:00210246(   - 00      -RIZP1) EAX:00000000
 EBX:7f22efc8 ECX:00000470 EDX:00000114 ESI:7f22f084 EDI:00000000
Stack dump:
0x7f22eefc:  7f22efc8 7f22f084 7ed14ff4 0000002b 0x7f22ef0c:  00000000
00000000 00000006 00000000 0x7f22ef1c:  00000000 00000000 00000000
00000000 0x7f22ef2c:  00000000 00000000 00000000 00000000 0x7f22ef3c: 
00000000 00000000 00000000 00000000 0x7f22ef4c:  00000000 00000000
00000000 00000000 Backtrace:
=>1 0x004ef87a in papyrus (+0xef87a) (0x7f22ef90)
  2 0x7ecba5ea in gdi32 (+0x2a5ea) (0x7f22f0f0) 3 0x7ecca77e
  WineEngEnumFonts+0x13e() in gdi32 (0x7f22f420) 4 0x7ecba907 in gdi32
  (+0x2a907) (0x7f22f480) 5 0x7ecba9af EnumFontFamiliesExA+0x2f() in gdi32
  (0x7f22f500) 6 0x7ecbaa24 EnumFontFamiliesA+0x64() in gdi32 (0x7f22f570)
  7 0x004efcec in papyrus (+0xefcec) (0x7f22f5f4) 8 0x004f5ba6 in papyrus
  (+0xf5ba6) (0x7f22fe44) 9 0x004f58bc in papyrus (+0xf58bc) (0x7f22fe7c)
  10 0x00552736 in papyrus (+0x152736) (0x7f22ff08) 11 0x7b87057e in
  kernel32 (+0x5057e) (0x7f22ffe8) 12 0xb7ea0717
  wine_switch_to_stack+0x17() in libwine.so.1 (0x00000000)
0x004ef87a: movl        0x18(%edi),%ecx Modules:

The full version is still avaiable at the link below.

If no-one can help directly, perhaps you could tell me where else I could
ask for help.

> On the same machine I can also boot into my Suse 10.0 setup
and Papyrus
> 12.56 runs fine in that.
> Both 10.0 and 10.2 are using the lastest wine version - 0.9.32-12.1.
> I have also tried an older version of wine for 10.2 without any success.
> Here you can see the console output from wine when I tried to run
> Papyrus 12.56 in 10.2.
> http://users.zetnet.co.uk/phwilliamson/Papyrus12_shell1.txt



More information about the wine-users mailing list