[Wine] Re: winecfg/pixel shading -> not working, various Steam (CS:S) ?s

wakeboarder3780 at gmail.com wakeboarder3780 at gmail.com
Mon Mar 5 17:42:45 CST 2007

On Mar 4, 1:36 pm, "jhanso... at gmail.com" <jhanso... at gmail.com> wrote:
> On Mar 3, 11:39 am, wakeboarder3... at gmail.com wrote:
> > wine version: 0.9.22
> Current version is 0.9.32
> > 1.)  A troubleshooting page I read said to try disabling the pixel
> > shader to gain fps.  As this was a good suggestion it somehow made the
> > game play much worse  I now pull about .1 fps.  When I ran winecfg
> > again to try to set it back, it check's the box just fine.  Even If I
> > run winecfg again to see that it "saved" my setting, it shows it is
> > still checked.  However when I enter a game, the pixels aren't shaded,
> > and the fps are still .1.  I even went into the user.reg file in my
> > USER/.wine directory and found the line:
> > [Software\\Wine\\Direct3D] 1172848535
> > "PixelShaderMode"="enabled"
> > Is there a known problem / fix for this that I just can't find?
> If Wine is set correctly then check the game's settings to see if it
> changed video settings in response to the change in Wine.
> > 2.)  At least in my opinion I think this is a sound related error.
> > When I try to load the audio tab in winecfg it chugs for about 5
> > seconds and gives me this "error":
> > error loading jack library libjack.so
> > then it says something about loading a default one for me.
> Jack audio is just another sound system option.  Try changing to only
> Alsa or only OSS.  Also try different settings for emulation and
> acceleration.  If possible, disable sound in the game to see if the
> problem goes away.
> > 3.)  I can only run Steam from root.  If I run it from my user i get a
> > huge long error I'm sure you are all familiar with.  What permissions
> > on what files do I need to change so I may run the command:
> > WINEDBUG="fixme-all" Steam.exe
> >From a terminal logged in as the normal user:
> chmod -R username:usergroup ~/.wine
> This will change all file ownership to "username" and "usergroup"
> except for some links in ~/.wine/dosdevices (don't change those unless
> they point to directories already owned by the user).
> If none of this works, rename the .wine directory and start a new
> one.  Just run winecfg and it should be created automatically.  Then
> pick reasonable settings for video, audio, and drive mappings and try
> installing the game again.  Don't override any DLLs initially.

Well the recursive chmod finda fixed it but I still had issues so I re-
installed wine using what you mentioned above and it seems to be
working better now.  Now I just need to figure out what i have to do
to get sound working properly.  Every time I shoot the frame rate
drops back down to near 10.  I don't know how you kill someone like
that, so I hope I can find some more resources on it.  If anyone else
has had a lot of problems with sound please let me know what you did
to get decent frame rates.  I have to use dxlevel 80 because it
performs the best by far, it's now a sound related issue.

More information about the wine-users mailing list