[Wine] Re: Strange Wine Error on Fedora

Declan Moriarty junk_mail at iol.ie
Wed May 2 03:16:25 CDT 2007

On Tue, 2007-05-01 at 15:55 -0400, Mintseris, Julian wrote:
> Hi,
> I saw a thread on this subject from about a month ago and the solution
> presented there doesn't quite work for me so I thought I'd try to
> revive it:
> I am running Fedora Core 6.  I had wine installed primarily in order
> to run a small dos app and it worked beautifully.  Yesterday, after a
> reboot, FC offered to update my packages, including wine, and I
> agreed.  Now, pretty much any wine command I run results in this:
> > winecfg
> drmUnmap back failed!
> ERROR!  mapping regions
> Segmentation fault
> In the previous thread, Skippyboy suggested running glxinfo as a
> diagnostic.  Unfortunately, that turns out to produce the same result:
> > glxinfo
> name of display: :0.0
> drmUnmap back failed!
> ERROR!  mapping regions
> Segmentation fault
> Any help would be appreciated.  My current (post-upgrade) wine version
> is 0.9.35-1
It sounds (wild guess) like your video driver is unhooked and you are
running on Vesa. I think it probably was a Fedora issue. Maybe there's
been a change in the way X reads that file (syntax dropped or
something). I can't find anything with a massively quick check, mind

I have Fedora core 5 and after the last update, X would not start. It
was trying to load the Vesa Driver, which isn't great for whatever
nvidia card I have. It failed. If your box came up, you mightn't notice
this, but video would be awry.

I hacked up a new /etc/X11/xorg.conf, and everything was fine.

Declan Moriarty <junk_mail at iol.ie>

More information about the wine-users mailing list