[Wine] COM port not accessible

Marco Aurélio Carvalho maurelioc at astrotec.com.br
Sun May 13 14:32:10 CDT 2007

Em Dom 13 Mai 2007, você escreveu:
> >>>>> "Marco" == Marco Aurélio Carvalho <maurelioc at astrotec.com.br> writes:
>     Marco> Hi folks, I need to use a program that access a serial port. The
>     Marco> link to the serial port in ~/.wine/dosdevices/ and permissions
>     Marco> are correct but at the terminal appears the following message:
>     Marco> fixme:comm:GetCommProperties (0x48 0x33edac )
>     Marco> and the program cannot access the serial port.  How could it be
>     Marco> fixed?
> Try to digg deeper, perhaps by running with relay debugging. Does the
> program really abort to access the serial port after the failing call to
> GetCommProperties()?
> Bye

The program do not crash, but it does not write or read from the serial port.
It presents an error message and continues but does not work. The program was 
compiled with Borland C builder (do not know the version).  I have the sorce 
code but not the compiler. It was created by a friend many years ago to help 
me test a electronic board.
I tried to use hyperterminal to test the serial port access, but I could not 
setup it properly or it does not work under wine.
I also tried to install an old terminal program called PROCOMM but the SETUP 
program complains that  a SHELL.DLL was not found and aborts.
I am triyng to find a simple terminal that uses a serial port to test it.

Marco Aurélio

More information about the wine-users mailing list