[Wine] COM port not accessible

Marco Aurélio Carvalho maurelioc at astrotec.com.br
Tue May 15 20:34:14 CDT 2007

Em Seg 14 Mai 2007, Declan Moriarty escreveu:
> On Sun, 2007-05-13 at 16:32 -0300, Marco Aurélio Carvalho wrote:
> > Em Dom 13 Mai 2007, você escreveu:
> > > >>>>> "Marco" == Marco Aurélio Carvalho <maurelioc at astrotec.com.br>
> > > >>>>> writes:
> > >
> > >     Marco> Hi folks, I need to use a program that access a serial port.
> > > The
> >
> > The program do not crash, but it does not write or read from the serial
> > port. It presents an error message and continues but does not work. The
> > program was compiled with Borland C builder (do not know the version).  I
> > have the sorce code but not the compiler. It was created by a friend many
> > years ago to help me test a electronic board.
> > I tried to use hyperterminal to test the serial port access, but I could
> > not setup it properly or it does not work under wine.
> > I also tried to install an old terminal program called PROCOMM but the
> > SETUP program complains that  a SHELL.DLL was not found and aborts.
> > I am triyng to find a simple terminal that uses a serial port to test it.
> Am I correct in thinking that this port has to communicate with a cpu on
> your test board which is talking via i2c boosted to rs-232 levels? Your
> firmware will have the baud rate set, along with parity, and error bits.
> Do you know what these settings should be? And some of the older
> circuits for this are inadequate, not meeting RS232 specs.
> Probably it is smartest to try to talk or listen in linux first, to get
> past those errors.
> man setserial is your friend.

The problem is not with my board or the serial HW. The external circuits use 
correct RS232 levels with 8N1 and 57600 baud. I can use the program inside a 
XP that runs inside VMware of the same machine. I am trying to run the SW 
directly on Linux with wine. 

Marco Aurélio

More information about the wine-users mailing list