[Wine] Should I report my problem in Bugzilla? Outcast problem.

L. Rahyen research at science.su
Sun Nov 11 21:02:00 CST 2007

On Sunday November 11 2007 13:59, Rémi G. wrote:
> > Or get the fix from commit 7cd9a8f8dc9536393e4e6042ae18bfb89b8671e5.
> > apply the patch with:
> Thank you, this patch resolves my last error and I can compile Wine 0.9 :)
> > Most likely you tried to apply wrong version of the patch and forgot to
> > run "git-checkouf -f" before trying to apply right version of the patch.
> In fact I discovered that neither 0.9-gdi-freetype.diff nor
> 0.9-gdi-freetype-old.diff was working with some versions...

	That's OK if you can compile successfully.

> but it's  no 
> yet a problem as I'm able now to compile wine 0.9 ;)
> Then I fixed the segementation fault on wine startup by applying the
> commit : a68d293bae6cec6deafafb94972c9277791256b5.
> I had to modify line 69 to avoid a problem when patching (I don't know
> how I did but it works... see attachement "segfault.diff").
> So, to compile wine-0.9, I need to execute :
> patch -p1 < ~/0.9-wrc-parser.diff
> patch -p1 < ~/0.9-kernel-time.diff
> patch -p1 < ~/0.9-gdi-freetype-old.diff
> patch -p1 < ~/segfault.diff
> git show 7cd9a8f8dc9536393e4e6042ae18bfb89b8671e5 | patch -p1
> And in spite of the fact that it was said in the appdb that Outcast runs
> with Wine 0.9, I didn't success :-(
> 1) If I run Outcast.exe, the game asks me for CD2 (I need to find a
> crack...) and wine displays this error in console :
> err:reg:SCSI_getprocentry SCSI type line scan count error
> But, I can see an animation so it's encouraging.
> 2) If I run directly loader.exe, wine crashes with the output :
> fixme:ddraw:Main_DirectDraw_SetCooperativeLevel
> (0x7fdf56d0)->((nil),00000008)
> I got the same errors with the outcast demo while runing
> Outcast_demo.exe or loader.exe (but of course wine don't ask me the
> CD2!). I've tried different loader.exe versions.

	If I understand everything correctly, you can run the game (at least Demo), 
it doesn't ask CD2, shows an animation and then crash. Full version doesn't 
crash but ask for CD2. Is this correct?

> With wine 0.9.49, I got :
> Can't find master volume control
> fixme:win:EnumDisplayDevicesW ((null),0,0x34f820,0x00000000), stub!
> fixme:d3d:IWineD3DDeviceImpl_Release (0x1352c0) Device released with
> resources still bound, acceptable but unexpected
> fixme:d3d:dumpResources Leftover resource 0x134748 with type
> Perhaps should I try a regression test to find "when" theses errors appear?

	As far as I understand with 0.9.49 you even cannot see the introductory 
animation it just crashes immediately? If so you can try to find the patch 
that broke the game' start up - *maybe* with new one WINE version it will 
work if you revert bad commit: it is possible that it doesn't work with 0.9 
because of additional non-obvious incompatibilities with new libraries.
	But even if this isn't the case finding bad commit that prevent start up of 
the game will be helpful anyway because will help to resolve at least a part 
of the bug that prevent Outcase from running.
	If my understanding of your words wasn't correct then please describe 
behavior of the game in each case with more details.
	Thank you for using WINE.

More information about the wine-users mailing list