[Wine] VideoMemorySize registry key not being applied? [wine-1.1.2]

bradl3yj wineforum-user at winehq.org
Sat Aug 2 15:40:35 CDT 2008

I am using Ubuntu Hardy, using the latest release of wine from the wine repos. I have an nVidia 7600GT with 256MB of video memory. One windows game i installed, Medal of Honor Allied Assault, has a simple config utility that sets game settings based on your hardware. This utility is detecting only 64MB of video memory.

I tried setting it using wine regedit, HKCU>Software>Wine>Direct3d

Set a string value under that named "VideoMemorySize" and set it to 256, the MOHAA Config still reports 64MB. I tried setting it as a decimal DWORD value instead, same.

This could be a bug in the MOHAA config, but how do I know that other games are taking advantage of more than 64MB?

Other Details:
nVidia Proprietary Driver 173.14.09 (Installed using EnvyNG)

Output of lspci -v -s 01:00.0:

01:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GT] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: eVga.com. Corp. Unknown device c555
	Flags: bus master, fast devsel, latency 0, IRQ 18
	Memory at d0000000 (32-bit, non-prefetchable) [size=16M]
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	Memory at d1000000 (64-bit, non-prefetchable) [size=16M]
	I/O ports at a000 [size=128]
	[virtual] Expansion ROM at d2000000 [disabled] [size=128K]
	Capabilities: <access denied>

More information about the wine-users mailing list