[Wine] Error after upgrading kubuntu

jiachen wineforum-user at winehq.org
Tue Aug 5 10:58:42 CDT 2008

Hi there,

I recently upgraded my kubuntu system to 8.04.1 (Hardy Heron), and one of the my data collection software under wine gives me this error every time I run it.


err:ntdll:RtlpWaitForCriticalSection section 0x7b92b280 "syslevel.c: Win16Mutex" wait timed out in thread 001c, blocked by 0019, retrying (60 sec)
wine: Critical section 7b92b280 wait failed at address 0x7bc3a930 (thread 001c), starting debugger...
Unhandled exception: wait failed on critical section 0x7b92b280
err:seh:raise_exception Unhandled exception code c0000194 flags 0 addr 0x7bc3a930
Process of pid=0017 has terminated
No process loaded, cannot execute 'echo Modules:'
Cannot get info on module while no process is loaded
No process loaded, cannot execute 'echo Threads:'
process  tid      prio (all id:s are in hex)
        00000012    0
        0000000e    0
        0000000d    0
        00000016    0
        00000015    0
        00000011    0
        00000010    0
        0000001b    0
You must be attached to a process to run this command.
No process loaded, cannot execute 'detach'

Previously, my kubuntu version was 7.10 (Gutsy Gibbon), and this program (called DataStream) worked fine.

I googled "err:ntdll:RtlpWaitForCriticalSection" for solution and found a few posts.
Such as this one, 
I don't know what they mean by "switching to OSS or try driver emulation"

None of any other posts seems to give a solution.

I have not yet tried anything to fix this myself.

Does anyone know how to fix this?  Thanks.

More information about the wine-users mailing list