[Wine] Re: akmod-nvidia update, lose openGL functionality

JohnLocke wineforum-user at winehq.org
Thu Aug 14 21:13:51 CDT 2008

vitamin wrote:
> Reinstall drivers. If they don't work, downgrade to an older version.

Well, I tried that. I backed off to kernel (what I was running when everything worked). I tried to run "yum install kmod-nvidia", but got the same dang dependency errors:

Error: Missing Dependency: kernel-uname-r = is
 needed by package kmod-nvidia- (livna)

Seems kmod will /only/ work with kernel (which I don't have and don't really know how to update to that specific of a kernel).

So I installed akmod (in single user mode, after removing all nvidia drivers). I then fully removed Wine (all 11 packages of it and it's helper packages), and then reinstalled using just "yum install wine" (got back all 11 packages). Again, got right back to the point where openGL works fine for linux programs (compiz, linux games), but not for Wine. Still have the exact same error.

Have the drivers:

rpm -qa | grep nvidia

> glxinfo | grep direct
direct rendering: Yes

> glxinfo | grep server
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:

> glxinfo | grep client
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
client glx extensions:

> rpm -qai kmod\*86\*
Name        : kmod-nvidia-  Relocations: (not relocatable)
Version     : 173.14.12                         Vendor: (none)
Release     : 2.fc9                         Build Date: Thu 14 Aug 2008 07:38:14 PM MDT
Install Date: Thu 14 Aug 2008 07:38:20 PM MDT      Build Host: LinBob
Group       : System Environment/Kernel     Source RPM: nvidia-kmod-173.14.12-2.fc9.src.rpm
Size        : 10318592                         License: Redistributable, no modification permitted
Signature   : (none)
URL         : http://www.nvidia.com/
Summary     : nvidia kernel module(s) for
Description :
This package provides the nvidia kernel modules built for the Linux
kernel for the x86_64 family of processors.

No good. Wine refuses to run openGL apps now.

Here's the xorg (minus things like the keyboard):


# Xorg configuration created by livna-config-display

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"
        ModulePath   "/usr/lib64/xorg/modules/extensions/nvidia"
        ModulePath   "/usr/lib64/xorg/modules"

Section "Module"
        Load  "i2c"
        Load  "bitmap"
        Load  "ddc"
        Load  "freetype"
        Load  "int10"
        Load  "type1"
        Load  "vbe"
        Load  "glx"
        Load  "dbe"
        Load  "extmod"

Section "ServerFlags"
        Option      "AIGLX" "on"

Section "Monitor"
        Identifier   "ViewSonic"
        HorizSync    30.0 - 60.0
        VertRefresh  60.0 - 75.0
        Option      "DPMS"

Section "Device"
        Identifier  "GeForce 8800"
        Driver      "nvidia"
        Option      "AddARGBGLXVisuals" "True"

Section "Screen"
        Identifier "Screen0"
        Device     "GeForce 8800"
        Monitor    "ViewSonic"
        DefaultDepth     24
        Option      "RenderAccel" "True"
        Option      "AddARGBGLXVisuals" "True"
        SubSection "Display"
                Viewport   0 0
                Depth     24

Section "Extensions"
        Option      "Composite" "Enable"

There's got to be some simple step of wine missing something. I'm sitting on a clean install of wine, and a clean install of the drivers (that work!), so Wine is the only thing that can be broken right now (that I can think of).

Any ideas?

More information about the wine-users mailing list