[Wine] Could Not Locate Entry For HAL.DLL In Setup Log

Austin English austinenglish at gmail.com
Fri Dec 5 20:11:46 CST 2008

On Fri, Dec 5, 2008 at 7:58 PM, zenarcher <wineforum-user at winehq.org> wrote:
> Thanks again, Austin.
> I tried the first suggestion you made, figuring I should enter it from a terminal.  I tried once more to install, but received the same error.  I have not yet tried adding hal.dll to fakedll in tools/wine.inf, as I'm not exactly sure how to do that.

Make sure you're trying this in a clean ~/.wine.

> Here is the info from the install attempt:
> zenarcher at zenarcher-desktop:~$ winefile
> fixme:advapi:DecryptFileA "c:\\3e84d687233723271b1c7e8\\" 00000000
> fixme:setupapi:SetupInitializeFileLogA Stub (null), 0x5
> fixme:shell:IShellLinkA_fnGetPath (0x1470f0): WIN32_FIND_DATA is not yet filled.
> fixme:shell:DllCanUnloadNow stub
> fixme:shell:DllCanUnloadNow stub
> zenarcher at zenarcher-desktop:~$
> I don't know if this will be any help or not, but I found this Capital.log from my attempt to install, so I will include it, as well:

I don't see anything about hal in that log...

The other method is to edit wine.inf. It's included with your wine
package. Most likely, in /usr/share/wine/wine.inf. There's a section
of fake dlls:

;;some dlls have to be registered first



In the appropriate spot. Then, try in a clean ~/.wine.


More information about the wine-users mailing list