[Wine] Re: playing with Wine on Cygwin

jeffz wineforum-user at winehq.org
Sun Dec 28 20:28:31 CST 2008

David Gerard wrote:
> I'm currently playing with Wine on Cygwin on Windows 2000 on
> VirtualBox. Just to see what happens. Also to see how feasible Wine on
> Windows is from here.
> I've been updating the http://wiki.winehq.org/CygwinSupport page accordingly.
> With the 1.1.11 source tarball, I'm getting a compile error:
> internettransport.c:348: error:
> `Include_winsock_h_before_stdlib_h_or_use_the_MSVCRT_library'
> undeclared (first use in this function)
> internettransport.c:348: error: (Each undeclared identifier is
> reported only once
> internettransport.c:348: error: for each function it appears in.)
> internettransport.c:348: error: parse error before "infd"
> internettransport.c:379: warning: implicit declaration of function
> `Include_winsock_h_before_stdlib_h_or_use_the_MSVCRT_library'
> internettransport.c:379: error: `infd' undeclared (first use in this function)
> make[2]: *** [internettransport.o] Error 1
> make[2]: Leaving directory `/cygdrive/c/wine-1.1.11/dlls/inetcomm'
> make[1]: *** [inetcomm] Error 2
> make[1]: Leaving directory `/cygdrive/c/wine-1.1.11/dlls'
> make: *** [dlls] Error 2
> Looks like the sort of thing that happens when configure thinks you
> have something installed you don't.
> I realise this is on VirtualBox, so all results are to be taken with a
> large grain of salt. But is anyone else seeing this with Wine on
> Cygwin?
> Now to give Wine on mingw a try ...
> - d.

There's little reason to suspect virtualization for a compile time error.

Coincidentally, this bug also occurs on OpenBSD http://bugs.winehq.org/show_bug.cgi?id=16660

You could try the suggested fix attached to the bug report.

More information about the wine-users mailing list