[Wine] Europa Universalis 2 crash (Ubuntu 8.04 Wine 1.1.10)

Austin English austinenglish at gmail.com
Mon Dec 29 13:38:08 CST 2008

On Mon, Dec 29, 2008 at 1:18 PM, rayofash <wineforum-user at winehq.org> wrote:
> According to the AppDB EU2 1.09 has a platinum rating, but it's constantly crashing on me. I installed the game from the CD, updated to the latest version (1.09), and the game launches just fine. When it gets into the menu I notice that it's running a lot slower than it should be. I can start a single player game and it still runs slow, and then crashes. It doesn't matter what I do in the game, after about a minute it crashes. I can leave it at the main menu, start a game, a tutorial or whatever, it crashes.
> mpegsplit.c:179: FillBuffer: Assertion `length == len || length + 4 == len' failed.
> wine: Assertion failed at address 0xb7fa8410 (thread 003b), starting debugger...
> Backtrace:
> =>1 0xb7fa8410 (0x7c471728)
>  2 0xb7d08a01 abort+0x101() in libc.so.6 (0x7c471854)
>  3 0xb7d0010e __assert_fail+0xee() in libc.so.6 (0x7c471898)
>  4 0x7c6c4e2c in quartz (+0x34e2c) (0x7c471998)
>  5 0x7c6ccbfa in quartz (+0x3cbfa) (0x7c471a38)
>  6 0x7bc6f5ae call_thread_entry_point+0xe() in ntdll (0x7c471a48)
>  7 0x7bc70c12 in ntdll (+0x60c12) (0x7c471ae8)
>  8 0x7bc70e0d in ntdll (+0x60e0d) (0x7c4723d8)
>  9 0xb7e304fb start_thread+0xcb() in libpthread.so.0 (0x7c4724c8)
> 0xb7fa8410: popl        %ebp

Looks like a crash in quartz. You can try the native dll to work
around it. File a bug.


More information about the wine-users mailing list