[Wine] Wine broke my WindowsXP (can't login)

helix wineforum-user at winehq.org
Thu Feb 28 12:29:32 CST 2008


I recently wanted to try out the new 0.9.53 version (previously I had 0.9.35 installed), so I downloaded it from http://wine.budgetdedicated.com/archive/index.html (32-bit for Ubuntu Edgy, though I'm on x86_64) and installed it (did dpkg -r wine before), which went fine. Then I went on trying out some programs, but upon starting (say, winecfg), it filled the screen with messages like

> err:wineboot:ProcessWindowsFileProtection WFP: L"dpcdll.dll" error 0x800

(about a hundred or so) which I attributed to my Windows C: partition being mounted read-only. It did start, but I didn't want to wait the half-minute, so I re-mounted the C: partition as read-write (which, in hindsight, I shound't have done!) and all went fine... 
But, now I can't seem to logon into Windows. It boots up to the login window, but when I actually log into my account, all it shows is the wallpaper.

I ran

find /c -daystart -type f -mtime 1 -mmin -$((2*24*60-14*60-28)) -mmin +$((2*24*60-14*60-32))

to see what has changed on the C: partition when I ran Wine (which I've narrowed down to the time shown, namely yesterday between 14:28 and 14:32), and it came up with about 1000 files in c:/windows/system32 ...

Has anyone else experienced something similar? Any other ideas what might be the cause? (I first though maybe it has messed up some configuration files, but their modification times are later (well, ok, I did login after all)). Why does Wine have to write to the Windows partition anyway?

More information about the wine-users mailing list