[Wine] WIne 1.0 Not Installing My Games?

fergatron wineforum-user at winehq.org
Wed Jul 16 21:10:40 CDT 2008


I successfully installed Wine 1.0 through Fedora 9's package manager - boy was I excited.  The first thing I installed was World of Warcraft.  When I try to run it nothing happens.  So I run the command in the terminal:


env WINEPREFIX="/home/marc/.wine" wine "C:\Program Files\World of Warcraft\Launcher.exe"

...and I get this result.


err:ole:CoGetClassObject class {8856f961-340a-11d0-a96b-00c04fd705a2} not registered
err:ole:CoGetClassObject class {8856f961-340a-11d0-a96b-00c04fd705a2} not registered
err:ole:CoGetClassObject no class object {8856f961-340a-11d0-a96b-00c04fd705a2} could be created for context 0x3

It looks like something didn't go through to the Windows Registry.

First; I used to run the previous version of Wine 0.9.[something] on my Fedora 8 just two weeks ago and I was able to install and play WoW.  This go around, it didn't create my desktop icon nor is there an entry in my applications menu.  So; something went wrong.

Other than that - I've tried to install GTA: San Andreas, Battlefield 2 and some other others but none of them go through successfully.  Am I missing something.  I was playing GTA and WoW just fine on my older distro and version of Wine.  Thanks for any help.

Here's the Error I get from installing GTA
[Image: http://i347.photobucket.com/albums/p443/marcferguson/Screenshot-GrandTheftAutoSanAndreas.png ]

More information about the wine-users mailing list