[Wine] alt.Binz can't connect multiple threads

drysdan wineforum-user at winehq.org
Mon Jul 21 05:07:49 CDT 2008

I'm running Ubuntu 8.04.1 Hardy Heron, and Wine 1.0.

I've installed the usenet binaries downloader alt.Binz 0.25.0, which the AppDB says works flawlessly for most people, as does everything I can find online about running it in wine, including the alt.Binz homepage.

It installed without a problem, and starts up and runs with only minimal visual issues.  By every observation it seems to run great.  Except:

My usenet server allows me 12 concurrent connection threads, and using them together helps to get the best d/l speeds.  Having thus configured alt.Binz (and I'm fairly sure alt.Binz is configured correctly for the server, as I copied and checked all the settings from my XP installation of it), I try to connect and download as normal. alt.Binz shows 12 threads attempting to connect.

But only 1 thread will actually connect and transfer any information.  The other 11 just sit in the 'connecting...' state.  Eventually 2 or 3 might connect up, but it takes a long time to even time out and give me a 'could not connect' error.  It's supposed to time out after 10 seconds, and the normal behavior running under XP is to be very quick to respond.

I've tried bouncing it through a proxy, reinstalling, everything I could think of.  I tried a different Windows usenet binaries downloader, Grabit, and it connected fine when running under wine.

Is there some reason the network connection is being strange in alt.Binz? The actual transfer rate is fairly normal, but it's really sluggish, at best.   
Anybody wanna venture a guess as to what's going on and how to remedy it?  

Thanks a ton!!!

More information about the wine-users mailing list