[Wine] .NET 2.0 fails compiling assemblies on OSX

JMS wineforum-user at winehq.org
Tue Jul 22 12:53:48 CDT 2008

I'm running 1.1.1 on Mac OS X 10.5.4.
I have searched about this issue and found nothing and people are running .net apps fine so I think this is a particular problem with Darwine (osx build)

.NET installs fine via winetricks and then I can run simple .net apps like QuickGUIDGen, but having a look to the NGen log I noticed there were no assemblies installed (It's supposed to install mscorlib and so after the install.

I tried to install manually:

wine ngen.exe install "mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089" /NoDependencies

and installs fine,

Microsoft (R) CLR Native Image Generator - Version 2.0.50727.42
Copyright (C) Microsoft Corporation 1998-2002. All rights reserved.
Installing assembly mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089

but later, when I do 

wine ngen executequeueditems

I got

Exception from HRESULT: 0x80070057 (E_INVALIDARG)

This happens with win2k, with winxp you get E_Accessdenied everywhere
I have checked the keys corresponding to the CLR service in the Registry as well as .net ones and everything seems ok.

I would try with winxp if someone tells me how to pass over access_denied and so (I know sudo doesn't work)

I need this for Autocad 2008 (.net 1.1 is fully working on the other hand, we have autocad 2005 working like a charm). A single command "layer" depends on it, but it's a very important one.

More information about the wine-users mailing list