[Wine] Guild Wars

oViXo wineforum-user at winehq.org
Sun Jun 1 10:18:23 CDT 2008

I cant seem to get Guild Wars to run at all. When I launch it I I get an error "Guild Wars has encountered an unrecoverable graphics driver error and must terminate". This is a Guild Wars message and not a Wine message.

So I'll cover the basics. My system is a P4 3.2 Ghz with an AGP bus, and 2gigs of ram. I'm currently using an ATI based Sapphire 3850 AGP card 512m, and running Ubuntu (8.04), with Wine version 1.0-rc3. I have tried older versions of Wine but no change. (1.0-rc2, 9.59, and 9.61)

Using the 8.5 ATI linux drivers, I do have 3d acceleration. Compiz is working good, along with my native linux version of Quake 3 Arena, and Doom 3 converted to native. Also I've installed Quake 4 using Wine (all though it's not needed) just to check and see if Wine is properly working. So far no issues with Quake 4.

I've tried all the basics covered on the Wine App-DB page including switches and registry tweaks, so far nothing has helped.

A little background on the card is that ATI doesn't "support" the RV670 chip converted to the AGP bus. That means on a Windows XP or greater system, you have to use the graphics driver on the cd sent with the card, and can only use patches available at the Sapphire web page. I tried to install a ATI driver 8.5 (in Windows XP) from the ATI site, and when it got to installing the driver part it didn't recognize that I had an ATI card. Thats how I found out, after the fact of buying it.

Another problem, more of an annoyance, does anyone know how to disable the context menu that pops up using Wine when you hold the ALT key in and use the Right mouse button?

Any Ideas? Some help here is greatly appreciated!

More information about the wine-users mailing list