[Wine] Re: Which Wine Download?

Island wineforum-user at winehq.org
Sun Jun 15 13:47:48 CDT 2008

Zac, thanks for your guidance.  I tried a couple of times to compile & install on Debian Etch.  I tried (more or less) following Dan Kegel's 'dapper script', and your PCLinuxOS script, reaching 'Permission denied' using either approach.  I also tried following the instructions in the 'readme' file in rc5, and hit the same result.

Just after you posted your suggestions, rc5 was released and so I decided to try to follow your advice, but with the rc5 release.  Downloaded the rc5.bz2 to a drive with plenty of room, /mnt/hda3, unpacked it into '/wine-1.0.rc5' (I used this as a sub for the 'cur_wine' value in your script).  I commented out some of your script, and adapted the second part, starting at the 'cd cur_wine' line, and saved it as 'islandwinebuild'.  Here's the output:

island at islandinthesun:/mnt/hda3$ sh islandwinebuild.sh
islandwinebuild.sh: ./configure: /bin/sh: bad interpreter: Permission denied
make: *** No rule to make target `depend'.  Stop.
make: *** No rule to make target `install'.  Stop.
Done installing, wine is now located in ${INSTALL_PATH}.

The permissions on all the directories and files on /mnt/hda3 are rwx,rwx,rwx, fully recursively, though I notice that the non-executable files like text docs are only rw-,rw-,rw-.  I used KDE's Konqueror to set these permissions, so perhaps it decides whether some things are executable or not.

Eager for a really difficult time, I looked at the readme in rc5!  Very easy read, in fact, and makes compiling sound simple.  So gave it a try.  It advises running ./tools/wineinstall,  Here's the output:

island at islandinthesun:/mnt/hda3$ cd wine-1.0-rc5
island at islandinthesun:/mnt/hda3/wine-1.0-rc5$ ./tools/wineinstall
bash: ./tools/wineinstall: /bin/bash: bad interpreter: Permission denied
island at islandinthesun:/mnt/hda3/wine-1.0-rc5$

Having realised that the readme is not at all ferocious, I plucked up the courage to read further.  It says:

"Run programs as "wine program".  For more information and problem
resolution, read the rest of this file, the Wine man page, and
especially the wealth of information found at http://www.winehq.org."

I did read the rest of the file, but it didn't seem to help with the permission denied thing.  I wondered if the comment meant that, to avoid 'permission denied' problems, I had to log on as 'wine program' before I could run the ./tools/wineinstall or the ./configure lines etc in your script.  At the moment there is only 'root' and 'island' as users on this machine.

Nevertheless, I've learnt a lot, and certainly feel confident about having a another go at compiling.  Much thanks to you, though, because your script sets out the basic sequence we have to go through, and the readme adds useful details.

regards, Island

More information about the wine-users mailing list