[Wine] Wrong path to app.exe

John Sved wineforum-user at winehq.org
Thu Jun 19 04:42:53 CDT 2008


Yesterday (one day after its release) I installed WINE 1.0 via openSuSE 10.3 YAST - from repository.  I also installed WINE-DOORS 0.1.2.
(first I unistalled and deleted earlier test installations and .wine folder)

Then I installed IE6 via the WINE-DOORS list.  This also installed a lot of other windows stuff.  This is often advised to support other apps.  Very nice!

IE6 was then tested.  It appeared to work OK.
Then I installed via WINE-DOORS an app for work purposes.  WINE-DOORS also prompted for another windows app which then allows the help facility to actually display text.  Very nice!
I installed TomTom Home2 and that was also OK although there is still the plugdev groups problem for SuSE.

All apps were manually registered in the KDE apps menue.  This worked.

But later .....  

Now none of these installed apps start.

Here is what was report from a console.

####:/home/####/.wine/drive_c/Program Files/Internet Explorer # wine iexplorer. exe
wine: created the configuration directory '/root/.wine'
Could not load Mozilla. HTML rendering will be disabled.
wine: configuration in '/root/.wine' has been updated.
wine: could not load L"C:\\windows\\system32\\iexplorer.exe": Module not found

BIT  each app.exe is in its own folder .... not in system32

Somehow WINE has changed the path information.

I have tried the root folded.  IE6 was started.  Again the was a prompt to install gecko.  After the installation the IE6 wind was blank and a menu (for Gecko stuff ?) could be invoked.

Before WINE 1.0  the installed windows apps at least loaded and ran "normally".

Any suggestions?

More information about the wine-users mailing list