[Wine] strange display problems with configuring and running wine

Sekra wineforum-user at winehq.org
Sat Jun 28 11:05:34 CDT 2008

I am running Arch linux on my laptop and I installed wine a while back to check if one application I use would work with it or not. Well I couldnt get it running since it apparently uses MS .NET framework which doesnt seem to work very well with wine. 

But to the issue at hand. Today I decided to try off another application, well okay a game actually, and I ran winecfg as normal user to re-make all the directories etc but then I ended up with a odd problem. My screen went crazy and when I took a screenshot after a while it looked like this:

[Image: http://www.saunalahti.fi/hotti/pics/pic1.png ]

when in reality what I would see on my screen is this (picture taken with my camera):

[Image: http://www.saunalahti.fi/hotti/pics/pic2.jpg ]

if I run winecfg AGAIN after restarting my X server with ctrl-alt-backspace it works fine and no trouble. BUT when I try to run the game I wanted to try, the game works but the screen is distorted again.

I tried reinstalling wine with no luck so the problem must lie somewhere else. I'm not a newbie with computers since I've fiddled around with them my whole life but I am rather new to linux. 

I am running version 0.9.61 of wine since that is the current stable release in Arch linux repos. The odd thing is that a few weeks back when I installed wine for the first time it worked just fine. 

So could someone please help me figure out what to do next to get wine working again so I can play Slaves to Amarok II: Dwarf Fortress on my linux laptop too and not just on my windows desktop? Thank you for any advice you can give.

More information about the wine-users mailing list