[Wine] Re: Low Quality Sound and Video settings in TF2

vitamin wineforum-user at winehq.org
Sat May 3 11:40:10 CDT 2008

Sleaka J wrote:
> I have managed to get TF2 working at an acceptable framerate under Wine. However 3 problems arise when playing it.
> When I run the game, it always sets my texture detail level to "Low" when I can run at "High" or "Very High" with very little performance loss, but no matter what I do, whenever I exit and restart the game, it reverts the texture detail level back to "Low". I don't seem to be able to keep it at "Very High".

Have you set amount of memory your video card has? If not set:


To the size of your video memory in megabytes.

Sleaka J wrote:
> Secondly, when I start at the menu, the sound is high quality. As soon as I get into a game, the sound quality is quite obviously low and scratchy. I've got winecfg using ALSA as the sound engine and I've tried OSS (no difference) and Esound (sound skips badly, and still low quality).
> Thirdly, the speaker configuration is reset when I restart the game. I have a set of headphones that I use and would like to keep the settings to "Headphones", but when I restart the game, it always goes back to "2 Speakers".
> I'm running Ubuntu 8.04 and Wine 0.9.60 with the nVidia 169.12 drivers. I know there's nothing wrong with my video drivers as glxgears works perfectly and I have the Linux client of ET:QW installed and that runs just as well as my Windows ET:QW install does.
> If I haven't given enough info, just ask more questions and I'll be happy to answer them.

Did you kill pulseaudio before running Wine? It conflicts with Wine.

More information about the wine-users mailing list